summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Coutinho2015-06-19 19:23:30 -0300
committerRenato Coutinho2015-06-19 19:23:30 -0300
commit8198b520c7e0fcf634b289ce65f1ae1acd7bfaf8 (patch)
tree76b4266afbc2670553c9933ae13e374e52dc53a1
downloadaur-8198b520c7e0fcf634b289ce65f1ae1acd7bfaf8.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
3 files changed, 57 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..c7198f01947c
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-nodepy-git
+ pkgdesc = Python package for designing, analyzing, and testing numerical methods for initial value ODEs
+ pkgver = 0.5
+ pkgrel = 1
+ url = http://numerics.kaust.edu.sa/nodepy/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-numpy
+ depends = python2-sympy
+ source = git://github.com/ketch/nodepy.git
+
+pkgname = python2-nodepy-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d63c6eaa03f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-nodepy-git
+ pkgdesc = Python package for designing, analyzing, and testing numerical methods for initial value ODEs
+ pkgver = 0.5
+ pkgrel = 1
+ url = http://numerics.kaust.edu.sa/nodepy/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-numpy
+ depends = python2-sympy
+ source = git://github.com/ketch/nodepy.git
+ md5sums = SKIP
+
+pkgname = python2-nodepy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..466691b4eeb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Renato Coutinho <renato dot coutinho at gmail dot com>
+pkgname=python2-nodepy-git
+pkgver=0.5
+pkgrel=1
+pkgdesc="Python package for designing, analyzing, and testing numerical methods for initial value ODEs"
+arch=('i686' 'x86_64')
+url="http://numerics.kaust.edu.sa/nodepy/"
+license=('BSD')
+source=("git://github.com/ketch/nodepy.git")
+md5sums=('SKIP')
+
+depends=('python2' 'python2-numpy' 'python2-sympy')
+makedepends=('git' 'python2-distribute')
+
+#build() {
+#}
+
+package() {
+ cd ${srcdir}/nodepy
+ python2 setup.py install --prefix=/usr --root=${pkgdir}
+ install -D LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}