summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-29 19:03:23 +0200
committerPellegrino Prevete2023-06-29 19:03:23 +0200
commitfe63279bddfc474e49b454503d33dfb78ba388b5 (patch)
treea2faf00b4243e5a5835f35c7d122421638f32776
parent8d15f1296a2b1dde847100981ddc9a8b9110f992 (diff)
downloadaur-python2-notify.tar.gz
update pkg
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD65
2 files changed, 46 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acbcefe513df..4f1e532d25cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python2-notify
- pkgdesc = Python bindings for libnotify
+ pkgdesc = Python bindings for lib
pkgver = 0.1.1
pkgrel = 14
- url = http://www.galago-project.org/
+ url = https://web.archive.org/web/20210304223822//news/index.php
arch = i686
arch = x86_64
license = GPL
+ makedepends = ipfs-dlagent
makedepends = python2
depends = pygtk>=2.22.0
depends = libnotify>=0.7.1
conflicts = python-notify<=0.1.1-11
replaces = python-notify<=0.1.1-11
- source = https://www.galago-project.org/files/releases/source/notify-python/notify-python-0.1.1.tar.gz
+ source = notify-python-0.1.1::ipfs://QmUrkNKgBrRJ1ha4Yv7Mh7RCvTq1kRQWEWDLZmuLmcVLvU
source = libnotify07.patch
source = notify-python-0.1.1-fix-GTK-symbols.patch
sha512sums = f900d58e4004d199f718e458ebaa9b654c0040b848312f6fe5a885afbdf67c771fd3360b4cbf121b66404d750a7cce24f776c360568eadcefc9733e7f501cccf
@@ -19,4 +20,3 @@ pkgbase = python2-notify
sha512sums = a5f9f04b080425114950aaa7fc2e68ff3e32d092cd0f7a9ef212a37d8056e4a2d438d075921e66be541bbdcadb4602c14e5bb7443e7455dc7ebc923c4dbd0961
pkgname = python2-notify
-
diff --git a/PKGBUILD b/PKGBUILD
index 905ea6ddae41..4a5ecf2838f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,63 @@
-# Maintainer: Jonathon Fernyhough <jonathon "m2x +dotdev>
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+# Contributor: Jonathon Fernyhough <jonathon "m2x +dotdev>
# Contributor: Angel Velasquez <angvp@archlinux.org>
-pkgname=python2-notify
+_py="python2"
+_pkg="notify"
+pkgname="${_py}-${_pkg}"
pkgver=0.1.1
pkgrel=14
-pkgdesc="Python bindings for libnotify"
+pkgdesc="Python bindings for lib${pkg}"
arch=('i686' 'x86_64')
-url="http://www.galago-project.org/"
+_url="http://www.galago-project.org/"
+url="https://web.archive.org/web/20210304223822/${url}/news/index.php"
license=('GPL')
-depends=('pygtk>=2.22.0' 'libnotify>=0.7.1')
-makedepends=('python2')
-conflicts=('python-notify<=0.1.1-11')
-replaces=('python-notify<=0.1.1-11')
-source=(https://www.galago-project.org/files/releases/source/notify-python/notify-python-${pkgver}.tar.gz
- libnotify07.patch
- notify-python-0.1.1-fix-GTK-symbols.patch)
-sha512sums=('f900d58e4004d199f718e458ebaa9b654c0040b848312f6fe5a885afbdf67c771fd3360b4cbf121b66404d750a7cce24f776c360568eadcefc9733e7f501cccf'
- 'd8c9a829d9255c0e971f00f7ef0f337207f94cd89f67bc657f0bcc2dc18a50b138924e2f9ef878daad2372256f7656064071f7a7324292700044c93e990f17fc'
- 'a5f9f04b080425114950aaa7fc2e68ff3e32d092cd0f7a9ef212a37d8056e4a2d438d075921e66be541bbdcadb4602c14e5bb7443e7455dc7ebc923c4dbd0961')
+depends=(
+ 'pygtk>=2.22.0'
+ "lib${_pkg}>=0.7.1"
+)
+makedepends=(
+ "ipfs-dlagent"
+ "${_py}"
+)
+conflicts=("python-${_pkg}<=0.1.1-11")
+replaces=("python-${_pkg}<=0.1.1-11")
+_ipfs_msg=("Could not find %u. Manually download it to \"$(pwd)\", "
+ "or set up an ipfs:// DLAGENT in /etc/makepkg.conf.\"; exit 1")
+DLAGENTS+=(
+ "ipfs:///usr/bin/echo '${_ipfs_msg[*]}'"
+)
+source=(
+ "${_pkg}-python-${pkgver}::ipfs://QmUrkNKgBrRJ1ha4Yv7Mh7RCvTq1kRQWEWDLZmuLmcVLvU"
+ # "${url}/files/releases/source/${_pkg}-python/${_pkg}-python-${pkgver}.tar.gz"
+ "lib${_pkg}07.patch"
+ "${_pkg}-python-0.1.1-fix-GTK-symbols.patch")
+sha512sums=(
+ 'f900d58e4004d199f718e458ebaa9b654c0040b848312f6fe5a885afbdf67c771fd3360b4cbf121b66404d750a7cce24f776c360568eadcefc9733e7f501cccf'
+ 'd8c9a829d9255c0e971f00f7ef0f337207f94cd89f67bc657f0bcc2dc18a50b138924e2f9ef878daad2372256f7656064071f7a7324292700044c93e990f17fc'
+ 'a5f9f04b080425114950aaa7fc2e68ff3e32d092cd0f7a9ef212a37d8056e4a2d438d075921e66be541bbdcadb4602c14e5bb7443e7455dc7ebc923c4dbd0961')
prepare() {
- cd notify-python-$pkgver
+ cd "${_pkg}-python-${pkgver}"
- patch -Np1 -i ../libnotify07.patch
- patch -Np1 -i ../notify-python-0.1.1-fix-GTK-symbols.patch
+ patch -Np1 -i "../lib${_pkg}07.patch"
+ patch -Np1 -i "../${_pkg}-python-0.1.1-fix-GTK-symbols.patch"
./configure --prefix=/usr
- # WARNING - we touch src/pynotify.override in build because upstream did not rebuild pynotify.c
- # from the input definitions, this forces pynotify.c to be regenerated, at some point this can be removed
- touch src/pynotify.override
+ # WARNING - we touch src/pynotify.override in build because
+ # upstream did not rebuild pynotify.c from the input definitions,
+ # this forces pynotify.c to be regenerated, at some point this can be removed
+ touch "src/py${_pkg}.override"
}
build() {
- cd notify-python-$pkgver
+ cd "${_pkg}-python-${pkgver}"
make clean
make CFLAGS+=" -fcommon"
}
package() {
- cd notify-python-$pkgver
- make DESTDIR="$pkgdir" install
+ cd "${_pkg}-python-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}