summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2020-10-02 13:32:36 +0100
committerJonathon Fernyhough2020-10-02 13:32:36 +0100
commit8d15f1296a2b1dde847100981ddc9a8b9110f992 (patch)
tree1e1cd83133409ce3870d0112a5188022f530d35f
parent4c44a2df35152deab6e48e4cd1ea4731985de532 (diff)
downloadaur-8d15f1296a2b1dde847100981ddc9a8b9110f992.tar.gz
Tidy PKGBUILD. Work around GCC 10 -fno-common.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe1ac09a61dc..acbcefe513df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,7 @@ pkgbase = python2-notify
depends = libnotify>=0.7.1
conflicts = python-notify<=0.1.1-11
replaces = python-notify<=0.1.1-11
- source = http://www.galago-project.org/files/releases/source/notify-python/notify-python-0.1.1.tar.gz
+ source = https://www.galago-project.org/files/releases/source/notify-python/notify-python-0.1.1.tar.gz
source = libnotify07.patch
source = notify-python-0.1.1-fix-GTK-symbols.patch
sha512sums = f900d58e4004d199f718e458ebaa9b654c0040b848312f6fe5a885afbdf67c771fd3360b4cbf121b66404d750a7cce24f776c360568eadcefc9733e7f501cccf
diff --git a/PKGBUILD b/PKGBUILD
index 59e2350e7c82..905ea6ddae41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Jonathon Fernyhough <jonathon "manjaro +dotorg>
+# Maintainer: Jonathon Fernyhough <jonathon "m2x +dotdev>
# Contributor: Angel Velasquez <angvp@archlinux.org>
pkgname=python2-notify
@@ -12,30 +12,33 @@ depends=('pygtk>=2.22.0' 'libnotify>=0.7.1')
makedepends=('python2')
conflicts=('python-notify<=0.1.1-11')
replaces=('python-notify<=0.1.1-11')
-source=(http://www.galago-project.org/files/releases/source/notify-python/notify-python-${pkgver}.tar.gz
+source=(https://www.galago-project.org/files/releases/source/notify-python/notify-python-${pkgver}.tar.gz
libnotify07.patch
notify-python-0.1.1-fix-GTK-symbols.patch)
sha512sums=('f900d58e4004d199f718e458ebaa9b654c0040b848312f6fe5a885afbdf67c771fd3360b4cbf121b66404d750a7cce24f776c360568eadcefc9733e7f501cccf'
'd8c9a829d9255c0e971f00f7ef0f337207f94cd89f67bc657f0bcc2dc18a50b138924e2f9ef878daad2372256f7656064071f7a7324292700044c93e990f17fc'
'a5f9f04b080425114950aaa7fc2e68ff3e32d092cd0f7a9ef212a37d8056e4a2d438d075921e66be541bbdcadb4602c14e5bb7443e7455dc7ebc923c4dbd0961')
-build() {
- cd "${srcdir}/notify-python-${pkgver}"
+prepare() {
+ cd notify-python-$pkgver
- patch -Np1 -i "${srcdir}/libnotify07.patch"
- patch -Np1 -i "${srcdir}/notify-python-0.1.1-fix-GTK-symbols.patch"
+ patch -Np1 -i ../libnotify07.patch
+ patch -Np1 -i ../notify-python-0.1.1-fix-GTK-symbols.patch
./configure --prefix=/usr
# WARNING - we touch src/pynotify.override in build because upstream did not rebuild pynotify.c
# from the input definitions, this forces pynotify.c to be regenerated, at some point this can be removed
touch src/pynotify.override
+}
+build() {
+ cd notify-python-$pkgver
make clean
- make
+ make CFLAGS+=" -fcommon"
}
package() {
- cd "${srcdir}/notify-python-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd notify-python-$pkgver
+ make DESTDIR="$pkgdir" install
}