summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFiras Zaidan2022-08-05 19:44:21 +0200
committerFiras Zaidan2022-08-05 19:44:21 +0200
commitb3137c7472d1fe44d075b0a08693bf489e5a98aa (patch)
tree6f6f3da74325590a3fa8272c3b5a4ac4aa4cf3d4
parent4641194ed466347bbf98348bf848277ed8668016 (diff)
downloadaur-python2-numexpr.tar.gz
Update to v2.7.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 19 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3f7631affe9..84e5acd4b7d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = python2-numexpr
pkgdesc = Fast numerical array expression evaluator for Python, NumPy, PyTables, pandas
- pkgver = 2.6.9
+ pkgver = 2.7.3
pkgrel = 1
url = https://github.com/pydata/numexpr
arch = x86_64
+ arch = i686
+ arch = pentium4
license = MIT
makedepends = python2-setuptools
- makedepends = python2-numpy
- source = python2-numexpr-2.6.9.tar.gz::https://github.com/pydata/numexpr/archive/v2.6.9.tar.gz
- sha1sums = db6cbb412fb1f85f87814002b88d0e479cf3ac51
-
-pkgname = python2-numexpr
+ depends = python2>=2.7
+ depends = python2<2.8
depends = python2-numpy
+ source = python2-numexpr-2.7.3.tar.gz::https://github.com/pydata/numexpr/archive/v2.7.3.tar.gz
+ sha256sums = 00d6b1518605afe0ed10417e0ff07123e5d531c02496c6eed7dd4b9923238e1e
+pkgname = python2-numexpr
diff --git a/PKGBUILD b/PKGBUILD
index d36a60a0b607..75298635cde1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,30 @@
# Maintainer: Firas Zaidan <firas@zaidan.de>
+# Contributor: Erich Eckner <arch at eckner dot net>
# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
# Contributor: Sebastien Binet <binet@lblbox>
pkgname=python2-numexpr
-pkgver=2.6.9
+pkgver=2.7.3
pkgrel=1
pkgdesc="Fast numerical array expression evaluator for Python, NumPy, PyTables, pandas"
url="https://github.com/pydata/numexpr"
-arch=('x86_64')
+arch=('x86_64' 'i686' 'pentium4')
license=('MIT')
-makedepends=('python2-setuptools' 'python2-numpy')
-source=($pkgname-$pkgver.tar.gz::https://github.com/pydata/numexpr/archive/v$pkgver.tar.gz)
-sha1sums=('db6cbb412fb1f85f87814002b88d0e479cf3ac51')
-
-prepare() {
- cd "$srcdir/numexpr-$pkgver"
-
- sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
- -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
- -i $(find . -name '*.py')
-}
+depends=(
+ 'python2>=2.7'
+ 'python2<2.8'
+ 'python2-numpy'
+)
+makedepends=('python2-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/pydata/numexpr/archive/v$pkgver.tar.gz")
+sha256sums=('00d6b1518605afe0ed10417e0ff07123e5d531c02496c6eed7dd4b9923238e1e')
build() {
cd "$srcdir"/numexpr-$pkgver
python2 setup.py build
}
-
package() {
- depends=('python2-numpy')
-
cd "$srcdir"/numexpr-$pkgver
-
python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
-
install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}