summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Gildas MILLON2015-07-14 20:12:53 +0200
committerPierre-Gildas MILLON2015-07-14 20:12:53 +0200
commit47065052d1ee57ee5de453ed7a66120a2f0388f8 (patch)
tree7f394e2951a7b0690fd880f8d04794d3232aa142
downloadaur-47065052d1ee57ee5de453ed7a66120a2f0388f8.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb798d494f3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-nuxeo-drive
+ pkgdesc = Desktop synchronization of local folders with remote Nuxeo workspaces
+ pkgver = 2.0.0626
+ pkgrel = 1
+ url = https://github.com/nuxeo/nuxeo-drive
+ arch = any
+ license = GPLv2
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://github.com/nuxeo/nuxeo-drive/archive/release-2.0.0626.tar.gz
+ md5sums = e07715d709bd97ebad49d87ab04e76dd
+
+pkgname = python2-nuxeo-drive
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c672b5ac7e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Pierre-Gildas MILLON <pgmillon@gmail.com>
+
+pkgname=python2-nuxeo-drive
+pkgver=2.0.0626
+pkgrel=1
+pkgdesc="Desktop synchronization of local folders with remote Nuxeo workspaces"
+arch=('any')
+url="https://github.com/nuxeo/nuxeo-drive"
+license=('GPLv2')
+depends=('python2, python2-yappi>=0.94, python2-xattr>=0.7.7, python2-send2trash>=1.3.0, python2-argparse>=1.3.0, python2-coverage>=3.7.1, python2-esky>=0.9.8, python2-faulthandler>=2.4, python2-nose>=1.3.7, python2-poster>=0.8.1, python2-psutil>=3.0.1, python2-watchdog>=0.8.3, python2-universal-analytics-python>=0.2.4, python2-mock>=1.0.1, python2-crypto>=2.6.1, python2-qt4')
+makedepends=('python2-setuptools')
+source=("https://github.com/nuxeo/nuxeo-drive/archive/release-$pkgver.tar.gz")
+md5sums=('e07715d709bd97ebad49d87ab04e76dd')
+
+build() {
+ cd "${srcdir}/nuxeo-drive-release-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/nuxeo-drive-release-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}