summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2011-10-04 13:52:59 +0200
committerMassimiliano Torromeo2011-10-04 13:52:59 +0200
commit4eab7f667aea87c506e8712e1f46e1751bce7f5b (patch)
tree2dfeb6bc47fb8c8874532648a24b095b7ed48ef0
downloadaur-4eab7f667aea87c506e8712e1f46e1751bce7f5b.tar.gz
Added python2-oauth2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5235a4c94919
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-oauth2
+ pkgdesc = A fully tested, abstract interface to creating OAuth 1.0 clients and servers
+ pkgver = 1.5.211
+ pkgrel = 2
+ url = https://github.com/simplegeo/python-oauth2
+ arch = any
+ license = GPL
+ makedepends = python2-setuptools
+ depends = python2-httplib2
+ source = http://pypi.python.org/packages/source/o/oauth2/oauth2-1.5.211.tar.gz
+ sha256sums = 82a38f674da1fa496c0fc4df714cbb058540bed72a30c50a2e344b0d984c4d21
+
+pkgname = python2-oauth2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..338dcb77b9a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=python2-oauth2
+pkgver=1.5.170
+pkgrel=1
+_libname=${pkgname/python2-/}
+pkgdesc="A fully tested, abstract interface to creating OAuth clients and servers"
+arch=(any)
+url="https://github.com/simplegeo/python-oauth2"
+license=('GPL')
+depends=(python2)
+source=(http://pypi.python.org/packages/source/${_libname:0:1}/$_libname/$_libname-$pkgver.tar.gz)
+md5sums=(5cca4f4ce2225781c2d91e19aad207f5)
+
+build() {
+ cd "$srcdir/$_libname-$pkgver"
+ python2 setup.py install --root=$pkgdir
+}