summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2014-02-25 13:21:35 +0100
committerMassimiliano Torromeo2014-02-25 13:21:35 +0100
commit56f94ea142257f3f728ac8279eb9fcf40ce64f9e (patch)
tree46115dd4c9ac60eaee15fa22f5af38d4a83cfec2
parentb3973d9af6164337b756993a18f03179a34becb7 (diff)
downloadaur-56f94ea142257f3f728ac8279eb9fcf40ce64f9e.tar.gz
Fixed python{,2}-distribute dependencies
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac785b58fb9d..6f312b9ad111 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,25 @@
pkgname=python2-oauth2
pkgver=1.5.211
-pkgrel=1
+pkgrel=2
_libname=${pkgname/python2-/}
-pkgdesc="A fully tested, abstract interface to creating OAuth clients and servers"
+pkgdesc="A fully tested, abstract interface to creating OAuth 1.0 clients and servers"
arch=(any)
url="https://github.com/simplegeo/python-oauth2"
license=('GPL')
depends=(python2-httplib2)
-makedepends=(python2-distribute)
+makedepends=(python2-setuptools)
source=(http://pypi.python.org/packages/source/${_libname:0:1}/$_libname/$_libname-$pkgver.tar.gz)
-md5sums=(987ad7365a70e2286bd1cebb344debbc)
build() {
cd "$srcdir/$_libname-$pkgver"
- python2 setup.py install --root=$pkgdir
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_libname-$pkgver"
+ python2 setup.py install --skip-build -O1 --root="$pkgdir"
rm -rf "$pkgdir"/usr/lib/python*/site-packages/tests
}
+
+sha256sums=('82a38f674da1fa496c0fc4df714cbb058540bed72a30c50a2e344b0d984c4d21')