summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2015-11-22 08:32:42 -0500
committerDaniel M. Capella2015-11-22 08:32:42 -0500
commitdb063b61f430d5a7184b09bd37f594c8814b2ac7 (patch)
tree7b114643633aa85c66ca370c3357eb945776ed20
parented995cd6c7ff6b245a4287e340660655efd0b019 (diff)
downloadaur-db063b61f430d5a7184b09bd37f594c8814b2ac7.tar.gz
change source to fork of v1.4.12
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eecd3c8d442d..e6f51b007721 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python2-oauth2client1412
pkgdesc = A client library for OAuth 2.0
pkgver = 1.4.12
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/google/oauth2client
arch = any
license = Apache
+ makedepends = git
makedepends = python2-setuptools
makedepends = python2-httplib2
makedepends = python2-pyasn1
@@ -12,8 +13,8 @@ pkgbase = python2-oauth2client1412
makedepends = python2-rsa
makedepends = python2-six
optdepends = python2-gflags: for oauth2client.tools.run function
- source = https://pypi.python.org/packages/source/o/oauth2client/oauth2client-1.4.12.tar.gz
- md5sums = 829a05a559b43215d67947aaff9c11b5
+ source = git+https://github.com/polyzen/oauth2client#branch=python2-1.4.12
+ md5sums = SKIP
pkgname = python2-oauth2client1412
diff --git a/PKGBUILD b/PKGBUILD
index 838423213bfe..40c4cd72447d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,31 +5,23 @@
pkgname=python2-oauth2client1412
pkgver=1.4.12
-pkgrel=1
+pkgrel=2
pkgdesc='A client library for OAuth 2.0'
arch=('any')
url=https://github.com/google/oauth2client
license=('Apache')
-makedepends=('python2-setuptools' 'python2-httplib2' 'python2-pyasn1'
+makedepends=('git' 'python2-setuptools' 'python2-httplib2' 'python2-pyasn1'
'python2-pyasn1-modules' 'python2-rsa' 'python2-six')
optdepends=('python2-gflags: for oauth2client.tools.run function')
-source=("https://pypi.python.org/packages/source/o/oauth2client/oauth2client-$pkgver.tar.gz")
-md5sums=('829a05a559b43215d67947aaff9c11b5')
-
-prepare() {
- cd oauth2client-$pkgver
-
- sed -e "s|#!/usr/bin/env python$|#!/usr/bin/env python2|" \
- -i $(find . -name '*.py')
-}
+source=('git+https://github.com/polyzen/oauth2client#branch=python2-1.4.12')
+md5sums=('SKIP')
build() {
- cd oauth2client-$pkgver
+ cd oauth2client
python2 setup.py build
}
package() {
- cd oauth2client-$pkgver
+ cd oauth2client
python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
- mv "$pkgdir"/usr/lib/python2.7/site-packages/oauth2client{,1412}
}