summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:15:34 +0200
committerM0Rf302015-06-17 16:15:34 +0200
commit68bbcd891f5e6608a77186f897384be557079cb7 (patch)
tree4689f631c194b3793666bfffa769a0ac80065ee3
downloadaur-68bbcd891f5e6608a77186f897384be557079cb7.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
3 files changed, 55 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..484b99827662
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-obelisk
+ pkgdesc = Pure Python Obelisk + Bitcoin client side library
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/darkwallet/python-obelisk
+ arch = any
+ license = GPL
+ depends = python2
+ depends = python2-pyzmq
+ depends = python2-ecdsa
+ depends = python2-twisted
+ conflicts = python2-obelisk-git
+ replaces = python2-obelisk-git
+ source = https://pypi.python.org/packages/source/p/python-obelisk/python-obelisk-0.1.3.tar.gz
+
+pkgname = python2-obelisk
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b3ab1878b14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-obelisk
+ pkgdesc = Pure Python Obelisk + Bitcoin client side library
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/darkwallet/python-obelisk
+ arch = any
+ license = GPL
+ depends = python2
+ depends = python2-pyzmq
+ depends = python2-ecdsa
+ depends = python2-twisted
+ conflicts = python2-obelisk-git
+ replaces = python2-obelisk-git
+ source = https://pypi.python.org/packages/source/p/python-obelisk/python-obelisk-0.1.3.tar.gz
+ md5sums = 3340c8e5a4b9918b9117fc66c64d95a4
+
+pkgname = python2-obelisk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fef50f248ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: M0Rf30
+
+pkgname=python2-obelisk
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Pure Python Obelisk + Bitcoin client side library"
+arch=(any)
+url="https://github.com/darkwallet/python-obelisk"
+license=('GPL')
+depends=('python2' 'python2-pyzmq' 'python2-ecdsa' 'python2-twisted')
+source=(https://pypi.python.org/packages/source/p/python-obelisk/python-obelisk-${pkgver}.tar.gz)
+conflicts=('python2-obelisk-git')
+replaces=('python2-obelisk-git')
+
+package(){
+ cd python-obelisk-${pkgver}
+ python2 setup.py install --root="$pkgdir"
+}
+
+md5sums=('3340c8e5a4b9918b9117fc66c64d95a4')