summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:16:07 +0200
committerM0Rf302015-06-17 16:16:07 +0200
commita0b306d847debdb3ef6d317714fe307f09bcea71 (patch)
treeec963ea8a7be75deff9cf037b5f50f132f6ca92d
downloadaur-a0b306d847debdb3ef6d317714fe307f09bcea71.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
3 files changed, 61 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..73df6e70c4e0
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-obelisk-git
+ pkgdesc = Pure Python Obelisk + Bitcoin client side library
+ pkgver = 100.2e7a67d
+ pkgrel = 1
+ url = https://github.com/darkwallet/python-obelisk
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2
+ depends = python2-pyzmq
+ depends = python2-ecdsa
+ depends = python2-twisted
+ provides = python2-obelisk
+ source = obelisk::git+https://github.com/darkwallet/python-obelisk.git
+
+pkgname = python2-obelisk-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5721e101e56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-obelisk-git
+ pkgdesc = Pure Python Obelisk + Bitcoin client side library
+ pkgver = 100.2e7a67d
+ pkgrel = 1
+ url = https://github.com/darkwallet/python-obelisk
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2
+ depends = python2-pyzmq
+ depends = python2-ecdsa
+ depends = python2-twisted
+ provides = python2-obelisk
+ source = obelisk::git+https://github.com/darkwallet/python-obelisk.git
+ md5sums = SKIP
+
+pkgname = python2-obelisk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eed7091ef4b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: M0Rf30
+
+_pkgname=python2-obelisk
+pkgname=$_pkgname-git
+pkgver=100.2e7a67d
+pkgrel=1
+pkgdesc="Pure Python Obelisk + Bitcoin client side library"
+arch=(any)
+url="https://github.com/darkwallet/python-obelisk"
+license=('GPL')
+depends=('python2' 'python2-pyzmq' 'python2-ecdsa' 'python2-twisted')
+makedepends=('git')
+source=('obelisk::git+https://github.com/darkwallet/python-obelisk.git')
+provides=('python2-obelisk')
+
+package(){
+ cd obelisk
+ python2 setup.py install --root="$pkgdir"
+}
+
+pkgver() {
+ cd obelisk
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+md5sums=('SKIP')