summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Schlichting2015-03-16 13:49:19 +0100
committerAndré Schlichting2015-03-16 13:49:19 +0100
commit714af696473f6d9ad61fadff767f85d9ae53b778 (patch)
tree2d6265a8397cb749e15cda4fd7dada3f7210bb0a
downloadaur-714af696473f6d9ad61fadff767f85d9ae53b778.tar.gz
initial maintained aur-packages
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rw-r--r--openant.install9
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1f42265ec4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-openant-git
+ pkgdesc = A python library to download and upload files from ANT-FS compliant devices (Garmin products).
+ pkgver = r86.4500761
+ pkgrel = 4
+ url = https://github.com/Tigge/openant
+ install = openant.install
+ arch = i686
+ arch = x86_64
+ license = custom:openant
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-pyusb-beta
+ optdepends = antfs-cli-git: To extract all activity FIT files from a device and write them to a folder.
+ source = git+https://github.com/Tigge/openant
+ md5sums = SKIP
+
+pkgname = python2-openant-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..467e78dafdd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Andre <andre-arch@delorus.de>
+pkgname=python2-openant-git
+_gitname=openant
+pkgver=r86.4500761
+pkgrel=3
+pkgdesc="A python library to download and upload files from ANT-FS compliant devices (Garmin products)."
+arch=('i686' 'x86_64')
+source=('git+https://github.com/Tigge/openant')
+url="https://github.com/Tigge/openant"
+license=("custom:${_gitname}")
+depends=('python2' 'python2-pyusb-beta')
+makedepends=('python2-setuptools')
+optdepends=('antfs-cli-git: To extract all activity FIT files from a device and write them to a folder.')
+install=openant.install
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_gitname}"
+
+ install -Dm644 resources/ant-usb-sticks.rules ${pkgdir}/etc/udev/rules.d/71-ant-usb-sticks.rules
+
+ sed -i 's/install_udev_rules(True)/install_udev_rules(False)/g' setup.py
+ sed -i 's/os.geteuid() == 0/False/' setup.py
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ install -Dm644 README.md ${pkgdir}/usr/share/${_gitname}/README
+
+ install -Dm644 LICENCE ${pkgdir}/usr/share/licenses/${_gitname}/LICENSE
+}
+
diff --git a/openant.install b/openant.install
new file mode 100644
index 000000000000..33689f432216
--- /dev/null
+++ b/openant.install
@@ -0,0 +1,9 @@
+post_install() {
+ udevadm control --reload-rules
+ udevadm trigger --subsystem-match=usb --attr-match=idVendor=0fcf --action=add
+ echo "udev rules reloaded."
+}
+
+post_upgrade() {
+ post_install $1
+}