summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrás Wacha2022-01-18 08:28:26 +0100
committerAndrás Wacha2022-01-18 08:28:26 +0100
commitc92e093d6481ed6eda5b3feb12c4ff136e429692 (patch)
tree0b99a242caf358d757f543ea2aca9740b0f91913
parent5d020fa0aab38b0a2f1df558698957b89b4b11ef (diff)
downloadaur-python2-openbabel.tar.gz
Upstream version 3.1.1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 777d04c746f2..1753f9c6e226 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-openbabel
pkgdesc = A library designed to interconvert between many file formats used in molecular modeling and computational chemistry: Python2 bindings
- pkgver = 3.0.0
+ pkgver = 3.1.1
pkgrel = 1
url = http://openbabel.org/wiki/Main_Page
arch = i686
@@ -11,13 +11,16 @@ pkgbase = python2-openbabel
makedepends = swig
depends = python2
depends = openbabel
- depends = wxgtk
+ depends = wxgtk3
depends = eigen
depends = boost-libs
+ depends = rapidjson
depends = python-rapidjson
depends = libxml2
- source = https://github.com/openbabel/openbabel/archive/openbabel-3-0-0.tar.gz
- md5sums = 4c0ba0ce5dac240b51dded72f69edbc0
+ depends = cairo
+ depends = boost
+ source = https://github.com/openbabel/openbabel/archive/refs/tags/openbabel-3-1-1.tar.gz
+ md5sums = 7efb864d2ba5593b286ddc49d70aa851
+ sha256sums = c97023ac6300d26176c97d4ef39957f06e68848d64f1a04b0b284ccff2744f02
pkgname = python2-openbabel
-
diff --git a/PKGBUILD b/PKGBUILD
index 95262e7757a5..731d587be962 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: András Wacha <awacha@gmail.com>
pkgname=(python2-openbabel)
-pkgver=3.0.0
+pkgver=3.1.1
pkgrel=1
pkgdesc="A library designed to interconvert between many file formats used in molecular modeling and computational chemistry: Python2 bindings"
arch=('i686' 'x86_64')
-depends=('python2' 'openbabel' 'wxgtk' 'eigen' 'boost-libs' 'python-rapidjson' 'libxml2')
+depends=('python2' 'openbabel' 'wxgtk3' 'eigen' 'boost-libs' 'rapidjson' 'python-rapidjson' 'libxml2' 'cairo' 'boost')
url="http://openbabel.org/wiki/Main_Page"
license=('GPL')
makedepends=('cmake' 'boost' 'swig')
-source=("https://github.com/openbabel/openbabel/archive/openbabel-3-0-0.tar.gz")
-md5sums=('4c0ba0ce5dac240b51dded72f69edbc0')
+source=("https://github.com/openbabel/openbabel/archive/refs/tags/openbabel-${pkgver//./-}.tar.gz")
+md5sums=('7efb864d2ba5593b286ddc49d70aa851')
+sha256sums=('c97023ac6300d26176c97d4ef39957f06e68848d64f1a04b0b284ccff2744f02')
prepare() {
mkdir -p build
@@ -19,7 +20,7 @@ prepare() {
build() {
cd build
- cmake ../openbabel-openbabel-3-0-0 \
+ cmake ../openbabel-openbabel-${pkgver//./-} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config \