summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTroy C2015-06-25 12:03:29 -0500
committerTroy C2015-06-25 12:03:29 -0500
commitd52c52c0c89fbfa67e4487fd29649561672af15a (patch)
tree503343ac49cb21377d6662fb957b0c4641d0b57b
downloadaur-d52c52c0c89fbfa67e4487fd29649561672af15a.tar.gz
Initial commit to AUR4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd7e57df69fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-os-networksv2-python-novaclient-ext
+ pkgdesc = Adds rackspace networks support to python-novaclient.
+ pkgver = 0.21
+ pkgrel = 5
+ url = http://pypi.python.org/pypi/os_networksv2_python_novaclient_ext/
+ arch = any
+ license = GPL
+ makedepends = python2-setuptools
+ depends = python2-novaclient
+ depends = python2-httplib2
+ depends = python2-prettytable
+ depends = python2-simplejson
+ depends = python2-iso8601
+ provides = python2-os-networksv2-python-novaclient-ext=0.21
+ source = http://pypi.python.org/packages/source/o/os_networksv2_python_novaclient_ext/os_networksv2_python_novaclient_ext-0.21.tar.gz
+ md5sums = caa62a3cecdd441c2d90ee9ec16769ee
+
+pkgname = python2-os-networksv2-python-novaclient-ext
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14a2cf8f577f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Troy C < rstrox -ta yahoo -tod com >
+
+pkgname=python2-os-networksv2-python-novaclient-ext
+pkgver=0.21
+pkgrel=5
+pkgdesc="Adds rackspace networks support to python-novaclient."
+arch=('any')
+url="http://pypi.python.org/pypi/os_networksv2_python_novaclient_ext/"
+license=('GPL')
+depends=('python2-novaclient' 'python2-httplib2' 'python2-prettytable' 'python2-simplejson' 'python2-iso8601')
+makedepends=('python2-setuptools')
+provides=("$pkgname=$pkgver")
+source=(http://pypi.python.org/packages/source/o/os_networksv2_python_novaclient_ext/os_networksv2_python_novaclient_ext-${pkgver}.tar.gz)
+md5sums=('caa62a3cecdd441c2d90ee9ec16769ee')
+
+build() {
+ cd "$srcdir/os_networksv2_python_novaclient_ext-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/os_networksv2_python_novaclient_ext-$pkgver"
+ python2 setup.py install --root=${pkgdir}
+}