summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErhan SAHIN2015-07-03 02:03:07 +0300
committerErhan SAHIN2015-07-03 02:03:07 +0300
commitb3f4cf2647686c1f23900cda52cc59006485df08 (patch)
tree226e6d3f1b0d4853cf92cf2160febd402e9a2eea
downloadaur-b3f4cf2647686c1f23900cda52cc59006485df08.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c5988b69ed7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-oslo-context-liberty
+ pkgdesc = Oslo Context library
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/oslo.context
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ provides = python2-oslo-context
+ source = https://pypi.python.org/packages/source/o/oslo.context/oslo.context-0.4.0.tar.gz
+ sha256sums = c980463a7ae5ceb83e8df89ca9ed351d813752f4ce62cdfe7b517c02b7b02c8c
+
+pkgname = python2-oslo-context-liberty
+ depends = python2-babel>=1.3
+ depends = python2-pbr>=0.6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7df7d435fcb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Erhan SAHIN < erhan@ssahin.net >
+
+pkgname="python2-oslo-context-liberty"
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Oslo Context library"
+arch=("any")
+url="https://pypi.python.org/pypi/oslo.context"
+license=("Apache")
+provides=("python2-oslo-context")
+makedepends=("python2-setuptools")
+source=("https://pypi.python.org/packages/source/o/oslo.context/oslo.context-${pkgver}.tar.gz")
+sha256sums=('c980463a7ae5ceb83e8df89ca9ed351d813752f4ce62cdfe7b517c02b7b02c8c')
+
+build() {
+ cd "${srcdir}/oslo.context-${pkgver}/"
+ python2 setup.py build
+}
+
+package_python2-oslo-context-liberty() {
+ depends=('python2-babel>=1.3' 'python2-pbr>=0.6')
+ cd "${srcdir}/oslo.context-${pkgver}/"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}