summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKartik Mohta2017-06-27 17:11:00 -0400
committerKartik Mohta2017-06-27 17:11:00 -0400
commitc1810ccdf8f67c1543d72d36472f6196796b7349 (patch)
treed1e002032ae96209c5a10d7de732e42b9a2598f8
downloadaur-c1810ccdf8f67c1543d72d36472f6196796b7349.tar.gz
Fully separate into Python 2 and 3 packages
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5b67337ae14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-osrf_pycommon
+ pkgdesc = Commonly needed Python modules, used by Python software developed at OSRF
+ pkgver = 0.1.3
+ pkgrel = 2
+ url = http://osrf-pycommon.readthedocs.org/
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-trollius
+ provides = python2-osrf-pycommon
+ conflicts = python2-osrf-pycommon
+ source = https://files.pythonhosted.org/packages/source/o/osrf_pycommon/osrf_pycommon-0.1.3.tar.gz
+ md5sums = c86d8f1603cc8c24fb19c7cd244387e9
+
+pkgname = python2-osrf_pycommon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90563cd2a84c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
+
+pkgbase=('python2-osrf_pycommon')
+pkgname=('python2-osrf_pycommon')
+_module='osrf_pycommon'
+pkgver='0.1.3'
+pkgrel=2
+pkgdesc="Commonly needed Python modules, used by Python software developed at OSRF"
+url="http://osrf-pycommon.readthedocs.org/"
+depends=('python2' 'python2-trollius')
+provides=('python2-osrf-pycommon')
+conflicts=('python2-osrf-pycommon')
+makedepends=('python2-setuptools')
+license=('Apache')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/o/osrf_pycommon/osrf_pycommon-${pkgver}.tar.gz")
+md5sums=('c86d8f1603cc8c24fb19c7cd244387e9')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}