summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiklas2018-08-30 17:44:14 +0200
committerNiklas2018-08-30 17:44:14 +0200
commit0e2ac2f9431e4c7e915d56f3e2fd01137d6ec20f (patch)
treeb770418577cc3172b03f22407f2c2aa411626ca4
downloadaur-0e2ac2f9431e4c7e915d56f3e2fd01137d6ec20f.tar.gz
[1.2.0-1] initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8920764cd19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-otr
+ pkgdesc = Off-The-Record Messaging (OTR) protocol implementation for python
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/AGProjects/python-otr
+ arch = any
+ license = LGPL2.1
+ depends = python2
+ source = https://files.pythonhosted.org/packages/source/p/python-otr/python-otr-1.2.0.tar.gz
+ sha512sums = 4230fdc4246b366c49a9593280775e65b38be9083e72e0f93b974fdf3b2fb374b87925b7b0f842c2e62f12a7b5df7f3a7bc8e1dd11406187f6bf7e73b1481010
+
+pkgname = python2-otr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..51232a58c781
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+gitsrc/
+*.tar.gz
+*.tar.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..545fefdb4d12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Niklas <dev@n1klas.net>
+
+pkgname=python2-otr
+_name=python-otr
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Off-The-Record Messaging (OTR) protocol implementation for python"
+arch=('any')
+url="https://github.com/AGProjects/python-otr"
+license=('LGPL2.1')
+depends=('python2')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha512sums=('4230fdc4246b366c49a9593280775e65b38be9083e72e0f93b974fdf3b2fb374b87925b7b0f842c2e62f12a7b5df7f3a7bc8e1dd11406187f6bf7e73b1481010')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --skip-build --optimize=1
+}