summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Shunick2016-07-14 02:57:36 -0400
committerAndrew Shunick2016-07-14 02:57:36 -0400
commit66407dc2c0e1112502cf8dd98c8afdafb397ef42 (patch)
tree455dfaf3401bfe5d287b49b74b8758e118e6a31d
downloadaur-66407dc2c0e1112502cf8dd98c8afdafb397ef42.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--CMakeLists-fix.patch17
-rw-r--r--PKGBUILD32
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..146be3437a84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-pachi_py-git
+ pkgdesc = Pachi (game of Go) environment for OpenAI gym
+ pkgver = r18.9cb949b
+ pkgrel = 1
+ url = https://gym.openai.com/
+ arch = any
+ license = GPLv2
+ makedepends = python2-setuptools
+ makedepends = gcc
+ makedepends = cmake
+ depends = python2
+ depends = python2-numpy
+ provides = python2-pachi_py
+ source = python2-pachi_py-git::git+https://github.com/openai/pachi-py
+ sha512sums = SKIP
+
+pkgname = python2-pachi_py-git
+
diff --git a/CMakeLists-fix.patch b/CMakeLists-fix.patch
new file mode 100644
index 000000000000..4ad9d8a4ba28
--- /dev/null
+++ b/CMakeLists-fix.patch
@@ -0,0 +1,17 @@
+diff --git a/pachi_py/pachi/CMakeLists.txt b/pachi_py/pachi/CMakeLists.txt
+index fb75fa4..c08c9f3 100644
+--- a/pachi_py/pachi/CMakeLists.txt
++++ b/pachi_py/pachi/CMakeLists.txt
+@@ -21,8 +21,10 @@ set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin
+ CACHE PATH "Output directory for executables and DLL's.")
+
+-list(APPEND CMAKE_C_FLAGS "-std=c99")
+-list(APPEND CMAKE_CXX_FLAGS "-std=c++11")
++SET( CMAKE_C_FLAGS "${CMAKE_CXX_FLAGS} -std=c99" )
++SET( CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -std=c++11" )
++#list(APPEND CMAKE_C_FLAGS "-std=c99")
++#list(APPEND CMAKE_CXX_FLAGS "-std=c++11")
+
+ # list(APPEND CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
+ # include(${CMAKE_SOURCE_DIR}/cmake/UseCython.cmake)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eddb3814a561
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Andrew Shunick <aur at shunick dot info>
+pkgname=python2-pachi_py-git
+pkgver=r18.9cb949b
+pkgrel=1
+pkgdesc="Pachi (game of Go) environment for OpenAI gym"
+arch=('any')
+url="https://gym.openai.com/"
+giturl="https://github.com/openai/pachi-py"
+license=('GPLv2')
+provides=('python2-pachi_py')
+depends=('python2' 'python2-numpy')
+makedepends=('python2-setuptools' 'gcc' 'cmake')
+source=("${pkgname}::git+${giturl}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $pkgname
+ patch -Np1 < ../../CMakeLists-fix.patch
+}
+
+package() {
+ cd $pkgname
+ env CC=gcc
+ env CXX=gcc
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+