summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2022-09-30 11:58:45 +0000
committerPellegrino Prevete2022-09-30 11:58:45 +0000
commitef5b1b96d5818ec4bf0034f1ee5402c6cff22851 (patch)
tree784818c02e6553ed6bd21b93f08e519461c103c0
parent77c7fb3509f29b85124da6cd43b429ad6da37360 (diff)
downloadaur-ef5b1b96d5818ec4bf0034f1ee5402c6cff22851.tar.gz
should work now
-rw-r--r--PKGBUILD19
1 files changed, 3 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d2e387316102..ab241f9aef2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,28 +13,15 @@ arch=('any')
url="https://github.com/pypa/${_name}"
license=('Apache')
makedepends=('python2-setuptools' 'python2-pyparsing')
-checkdepends=('python-pytest' 'python-pretend')
-source=("https://github.com/pypa/${_name}/archive/${pkgver}/${_pkgbase}-${pkgver}.tar.gz"
- replace-distutils-usage-with-sysconfig.patch)
-sha512sums=('fb71f1036cfaacbe94fdee663af31d6ad1960f73ecc95cba87b461c2d7d2ea90085853bb4682b146492d8c48f784b60ef082e3b1259269857166b143cd9a920b'
- '015ddcb799259190e3a4b97d386fb8e4cb6f76a22eed2ce97babf10116e886b82f6f3e3e74e3590dd14a8fce8e6ca5980a91205c61e29afa5dbdc387f4daa8dd')
-
-prepare() {
- cd "${_name}-${pkgver}" || exit
- patch -Np1 -i ../replace-distutils-usage-with-sysconfig.patch
-}
+checkdepends=('python2-pytest' 'python-pretend')
+source=("https://github.com/pypa/${_name}/archive/${pkgver}/${_pkgbase}-${pkgver}.tar.gz")
+sha512sums=('fb71f1036cfaacbe94fdee663af31d6ad1960f73ecc95cba87b461c2d7d2ea90085853bb4682b146492d8c48f784b60ef082e3b1259269857166b143cd9a920b')
build() {
cd "${_name}-${pkgver}" || exit
- python setup.py build
python2 setup.py build
}
-check() {
- cd "${_name}-${pkgver}" || exit
- python -m pytest
-}
-
# shellcheck disable=SC2154
package() {
depends=('python2-pyparsing' 'python2-six')