summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commit13a580044042b3fe8d0e7ff9602b465d730a8e17 (patch)
tree25972b63c1c0c08574bd35fa2f5b4f1fcc57de61
downloadaur-13a580044042b3fe8d0e7ff9602b465d730a8e17.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE25
-rw-r--r--PKGBUILD38
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e149e758cfa4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python2-palm
+ pkgdesc = Fast protocol buffer library for Python (Protobufs Are Lightweight Messages)
+ pkgver = 0.1.7
+ pkgrel = 2
+ url = https://github.com/bumptech/palm
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = python2-setuptools
+ depends = python2
+ provides = palmc
+ provides = python2-palm
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/p/palm/palm-0.1.7.tar.gz
+ source = LICENSE
+ md5sums = f49942ae4746191e73e0935c4c31c6ae
+ md5sums = 6d0bd0996abe85ce1b772cbe989160c8
+ sha256sums = 4d6f4cb18ae861ac99c27abb454fdce06a627aa326fb6d8e81ce2c5d0f483ac7
+ sha256sums = 6b7c8132ae8c56d2090dbecf0e66a91bf06f6ed3d75ae4e7a001d69fa22990b1
+
+pkgname = python2-palm
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..df4d414075eb
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,25 @@
+Copyright 2012 Bump Technologies, Inc. All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are
+permitted provided that the following conditions are met:
+
+ 1. Redistributions of source code must retain the above copyright notice, this list of
+ conditions and the following disclaimer.
+
+ 2. Redistributions in binary form must reproduce the above copyright notice, this list
+ of conditions and the following disclaimer in the documentation and/or other materials
+ provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY BUMP TECHNOLOGIES, INC. ``AS IS'' AND ANY EXPRESS OR IMPLIED
+WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
+FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL BUMP TECHNOLOGIES, INC. OR
+CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
+ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+The views and conclusions contained in the software and documentation are those of the
+authors and should not be interpreted as representing official policies, either expressed
+or implied, of Bump Technologies, Inc.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fbe07513461
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-palm
+pkgver=0.1.7
+pkgrel=2
+pkgdesc="Fast protocol buffer library for Python (Protobufs Are Lightweight Messages)"
+arch=('i686' 'x86_64')
+depends=('python2')
+makedepends=('python2-setuptools')
+url="https://github.com/bumptech/palm"
+license=('custom')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/p/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz
+ LICENSE)
+md5sums=('f49942ae4746191e73e0935c4c31c6ae'
+ '6d0bd0996abe85ce1b772cbe989160c8')
+sha256sums=('4d6f4cb18ae861ac99c27abb454fdce06a627aa326fb6d8e81ce2c5d0f483ac7'
+ '6b7c8132ae8c56d2090dbecf0e66a91bf06f6ed3d75ae4e7a001d69fa22990b1')
+provides=('palmc' 'python2-palm')
+
+prepare(){
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Fixing Python version...'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python#/usr/bin/python2#g'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/env python#/usr/bin/env python2#g'
+}
+
+package() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Installing license...'
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -D -m644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}