summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2021-10-02 21:29:39 +0100
committerSpyros Stathopoulos2021-10-02 21:29:39 +0100
commit5d1ef0d3cf3d27373543e1c31206af8ccddaa884 (patch)
tree9fea180d51c089d5c65199d43ce4df0b5296c9f8
parent3aa9d7b68cd48bfda549e4e4538ab7a622b21f22 (diff)
downloadaur-5d1ef0d3cf3d27373543e1c31206af8ccddaa884.tar.gz
Clean up dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD41
2 files changed, 21 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9269c184b964..7be8eb62a085 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python2-pandas
pkgdesc = R-like data analysis library for Python (final Python 2.x version).
pkgver = 0.24.2
- pkgrel = 1
+ pkgrel = 2
url = http://pandas.pydata.org
arch = i686
arch = x86_64
license = BSD
makedepends = cython2
+ makedepends = python2-setuptools
depends = python2
depends = python2-numpy
depends = python2-dateutil
@@ -15,10 +16,7 @@ pkgbase = python2-pandas
optdepends = python2-scipy: for miscellaneous statistical functions
optdepends = python2-pytables: for HDF5-based storage
optdepends = python2-matplotlib: for plotting
- optdepends = scikits-statsmodels: for parts of pandas.stats
optdepends = python2-openpyxl>=1.6.1: for Excel I/O
- optdepends = python2-xlrd: for Excel I/O
- optdepends = python2-xlwt: for Excel I/O
optdepends = python2-boto: for Amazon S3 access
optdepends = python2-beautifulsoup4: for read_html function
optdepends = python2-html5lib: for read_html function
@@ -27,4 +25,3 @@ pkgbase = python2-pandas
md5sums = 6640de14a934a701129b635c6d75801d
pkgname = python2-pandas
-
diff --git a/PKGBUILD b/PKGBUILD
index 3ec40caa176f..0ae9ce51e15a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,25 @@
# Contributor: Spyros Stathopoulos <spystath@gmail.com>
-pkgname="python2-pandas"
-_pkgname="pandas"
+pkgname=python2-pandas
+_pkgname=pandas
pkgver=0.24.2
-pkgrel=1
-pkgdesc="R-like data analysis library for Python (final Python 2.x version)."
-url="http://pandas.pydata.org"
+pkgrel=2
+pkgdesc='R-like data analysis library for Python (final Python 2.x version).'
+url='http://pandas.pydata.org'
depends=('python2' 'python2-numpy' 'python2-dateutil')
-optdepends=("python2-numexpr: for accelerating certain numerical operations (recommended)"
- "python2-bottleneck: for accelerating certain types of nan evaluations (recommended)"
- "python2-scipy: for miscellaneous statistical functions"
- "python2-pytables: for HDF5-based storage"
- "python2-matplotlib: for plotting"
- "scikits-statsmodels: for parts of pandas.stats"
- "python2-openpyxl>=1.6.1: for Excel I/O"
- "python2-xlrd: for Excel I/O"
- "python2-xlwt: for Excel I/O"
- "python2-boto: for Amazon S3 access"
- "python2-beautifulsoup4: for read_html function"
- "python2-html5lib: for read_html function"
- "python2-lxml: for read_html function")
-makedepends=("cython2")
-arch=("i686" "x86_64")
-license=("BSD")
-md5sums=("6640de14a934a701129b635c6d75801d")
+optdepends=('python2-numexpr: for accelerating certain numerical operations (recommended)'
+ 'python2-bottleneck: for accelerating certain types of nan evaluations (recommended)'
+ 'python2-scipy: for miscellaneous statistical functions'
+ 'python2-pytables: for HDF5-based storage'
+ 'python2-matplotlib: for plotting'
+ 'python2-openpyxl>=1.6.1: for Excel I/O'
+ 'python2-boto: for Amazon S3 access'
+ 'python2-beautifulsoup4: for read_html function'
+ 'python2-html5lib: for read_html function'
+ 'python2-lxml: for read_html function')
+makedepends=('cython2' 'python2-setuptools')
+arch=('i686' 'x86_64')
+license=('BSD')
+md5sums=('6640de14a934a701129b635c6d75801d')
source=("https://github.com/pandas-dev/pandas/releases/download/v${pkgver}/pandas-${pkgver}.tar.gz")