summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZachary Vance2020-06-04 17:02:20 -0700
committerZachary Vance2020-06-04 17:02:20 -0700
commita4a3c316651f0c8762eabb43aefe324bbf5d5e60 (patch)
tree80b495a262a8227bf6134fb559eeee7c5d388e97
downloadaur-a4a3c316651f0c8762eabb43aefe324bbf5d5e60.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27bce0499e10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-paramiko
+ pkgdesc = Python module that implements the SSH2 protocol
+ pkgver = 2.7.1
+ pkgrel = 1
+ url = https://github.com/paramiko/paramiko/
+ arch = any
+ license = LGPL
+ makedepends = python2-setuptools
+ depends = python2-bcrypt
+ depends = python2-cryptography
+ depends = python2-pynacl
+ source = python2-paramiko-2.7.1.tar.gz::https://github.com/paramiko/paramiko/archive/2.7.1.tar.gz
+ sha512sums = 2cebed2420cf9af77cb0d459b64a74adcffcdb15bd58c8fc9243855ae91f43e16706665b64ce2851f6e99e59ca6a47d7299a2aae35a4c9d01ab97b343569c4b2
+
+pkgname = python2-paramiko
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a795cd84dc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Zachary Vance <za3k at za3k dot com>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: Mario Danic <mario.danic@gmail.com>
+
+pkgname=python2-paramiko
+pkgver=2.7.1
+pkgrel=1
+pkgdesc="Python module that implements the SSH2 protocol"
+url="https://github.com/paramiko/paramiko/"
+license=('LGPL')
+arch=('any')
+depends=('python2-bcrypt' 'python2-cryptography' 'python2-pynacl')
+makedepends=('python2-setuptools')
+#checkdepends=('python2-pytest-runner' 'python2-pytest' 'python2-pyasn1' 'python2-mock')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/paramiko/paramiko/archive/$pkgver.tar.gz")
+sha512sums=('2cebed2420cf9af77cb0d459b64a74adcffcdb15bd58c8fc9243855ae91f43e16706665b64ce2851f6e99e59ca6a47d7299a2aae35a4c9d01ab97b343569c4b2')
+
+# Check is disabled because it would involve maintaining at least 2 other python2 packages, both of which are neeeded ONLY by this check function.
+# This package will be removed in <3 months when it's ported to python3.
+check() {
+ #cd paramiko-$pkgver
+ #LANG=en_US.UTF-8 python2 setup.py pytest
+ :
+}
+
+package() {
+ cd paramiko-$pkgver
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -dm755 "$pkgdir"/usr/share/doc/$pkgname/demos
+ install -m644 demos/* "$pkgdir"/usr/share/doc/$pkgname/demos
+ chmod 755 "$pkgdir"/usr/share/doc/$pkgname/demos/*.py
+}