summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorParadoxSpiral2015-06-09 17:06:02 +0000
committerParadoxSpiral2015-06-09 17:06:02 +0000
commit891c3975517b9324e379d9fcbfec372731c96acc (patch)
tree7acaf58406c66c81af7008b15d329ee6f159cdcd
downloadaur-891c3975517b9324e379d9fcbfec372731c96acc.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44985646a1d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-paste-script
+ pkgdesc = A pluggable command-line frontend, including commands to setup package file layouts
+ pkgver = 1.7.5
+ pkgrel = 1
+ url = http://pythonpaste.org/script/
+ arch = any
+ license = custom
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-paste>=1.7
+ depends = python2-paste-deploy
+ optdepends = python2-cheetah: for templating
+ optdepends = python2-flup: utilities for WSGI
+ replaces = python-paste-script
+ source = http://pypi.python.org/packages/source/P/PasteScript/PasteScript-1.7.5.tar.gz
+ md5sums = 4c72d78dcb6bb993f30536842c16af4d
+
+pkgname = python2-paste-script
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c69a280b57a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Brad Pitcher <bradpitcher@gmail.com>
+# Contributor: David Campbell <davekong@archlinux.us>
+# Contributor: Cilyan Olowen <gaknar@gmail.com>
+
+pkgname=python2-paste-script
+pkgver=1.7.5
+pkgrel=1
+pkgdesc="A pluggable command-line frontend, including commands to setup package file layouts"
+arch=('any')
+url="http://pythonpaste.org/script/"
+license=('custom')
+depends=('python2' 'python2-paste>=1.7' 'python2-paste-deploy')
+optdepends=('python2-cheetah: for templating' 'python2-flup: utilities for WSGI')
+makedepends=('python2-distribute')
+source=(http://pypi.python.org/packages/source/P/PasteScript/PasteScript-${pkgver}.tar.gz)
+replaces=('python-paste-script')
+md5sums=('4c72d78dcb6bb993f30536842c16af4d')
+
+package() {
+ cd $srcdir/PasteScript-${pkgver}
+ python2 setup.py install --root=$pkgdir --optimize=1
+ install -Dm644 docs/license.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
+ sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ $(find $pkgdir -name '*.py')
+}