summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2022-06-11 23:40:24 -0300
committerDanilo J. S. Bellini2022-06-11 23:40:24 -0300
commitf071ebc938005441780cf2d2c55895066dd0d982 (patch)
treee55933c378a1096cf9a922e4be1fe2d922eb465d
downloadaur-f071ebc938005441780cf2d2c55895066dd0d982.tar.gz
Add v5.9.0-1 with pbr2 as script
This version is newer than the last from the community repository, it keeps "pbr2" as it used to be when python2-pbr was built together with python-pbr
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..767f6eee3a8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python2-pbr
+ pkgdesc = Python Build Reasonableness (for Python 2)
+ pkgver = 5.9.0
+ pkgrel = 1
+ url = https://pypi.python.org/pbr
+ arch = any
+ license = Apache
+ depends = python2-setuptools
+ source = https://pypi.python.org/packages/source/p/pbr/pbr-5.9.0.tar.gz
+ sha256sums = e8dca2f4b43560edef58813969f52a56cef023146cbb8931626db80e6c1c4308
+
+pkgname = python2-pbr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b75b883354a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+pkgname=python2-pbr
+_name="${pkgname#python2-}"
+pkgver=5.9.0
+pkgrel=1
+pkgdesc='Python Build Reasonableness (for Python 2)'
+arch=('any')
+_pypi='https://pypi.python.org'
+url="$_pypi/$_name"
+license=('Apache')
+depends=('python2-setuptools')
+source=("$_pypi/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('e8dca2f4b43560edef58813969f52a56cef023146cbb8931626db80e6c1c4308')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ mv "$pkgdir/usr/bin/pbr"{,2}
+}