summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandalenavals2017-11-01 06:58:49 -0200
committerandalenavals2017-11-01 06:58:49 -0200
commit100cd31844e34a64cf32f0b792692d6b1dd2c549 (patch)
treefe752c8f34d7164eeccb417be02a94c52e194a6d
downloadaur-100cd31844e34a64cf32f0b792692d6b1dd2c549.tar.gz
First release, tests must be reconfigure for python2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD55
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..153900cafd14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-pixmappy
+ pkgdesc = Python interface to gbdes pixel map (astrometry) solutions
+ pkgver = r40.5c82c73
+ pkgrel = 1
+ url = https://github.com/gbernstein/pixmappy
+ arch = any
+ license = BSD
+ makedepends = git
+ source = python2-pixmappy-r40.5c82c73::git+https://github.com/gbernstein/pixmappy
+ md5sums = SKIP
+
+pkgname = python2-pixmappy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cde7eb22f646
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: G. Bernstein, M. Jarvis and E. Sheldon
+pkgname=python2-pixmappy
+pkgver=r40.5c82c73
+pkgrel=1
+#epoch=
+
+pkgdesc=" Python interface to gbdes pixel map (astrometry) solutions "
+
+
+arch=('any')
+url="https://github.com/gbernstein/pixmappy"
+license=('BSD')
+groups=()
+depends=()
+makedepends=('git')
+checkdepends=()
+optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver::git+${url}")
+#noextract=()
+md5sums=('SKIP')
+#validpgpkeys=()
+
+
+build() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ python2 setup.py build
+}
+
+
+pkgver() {
+ cd "$pkgname-$pkgver"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ python2 setup.py install --root=${pkgdir} --prefix=/usr
+
+}