summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorInfernio2020-10-10 16:41:46 +0200
committerInfernio2020-10-10 16:41:46 +0200
commit4df58d58edae648d51a7834a8eb7ee6d116f296b (patch)
tree5a7fe088b7a4d0dc13b65dbd929f0c1b930b00d5
downloadaur-4df58d58edae648d51a7834a8eb7ee6d116f296b.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ac7cb0357b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-pkgconfig
+ pkgdesc = Python 2 module to interface with the pkg-config command line tool
+ pkgver = 1.5.1
+ pkgrel = 4
+ url = https://github.com/matze/pkgconfig
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://pypi.io/packages/source/p/pkgconfig/pkgconfig-1.5.1.tar.gz
+ sha256sums = 97bfe3d981bab675d5ea3ef259045d7919c93897db7d3b59d4e8593cba8d354f
+
+pkgname = python2-pkgconfig
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e12b49f6e4cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Infernio <infernio at icloud dot com>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+
+pkgname=python2-pkgconfig
+pkgver=1.5.1
+pkgrel=4
+pkgdesc="Python 2 module to interface with the pkg-config command line tool"
+arch=(any)
+url="https://github.com/matze/pkgconfig"
+license=(MIT)
+depends=(python2)
+makedepends=(python2-setuptools)
+source=("https://pypi.io/packages/source/p/pkgconfig/pkgconfig-$pkgver.tar.gz")
+sha256sums=('97bfe3d981bab675d5ea3ef259045d7919c93897db7d3b59d4e8593cba8d354f')
+
+package() {
+ cd pkgconfig-$pkgver
+
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}