summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-07-05 03:34:52 +0200
committerPellegrino Prevete2023-07-05 03:34:52 +0200
commitf7e47e57819c7a75645e72846311762aca1d6446 (patch)
tree4dcc6e184d674da942b73235ae242262873b3e59
parent4df58d58edae648d51a7834a8eb7ee6d116f296b (diff)
downloadaur-f7e47e57819c7a75645e72846311762aca1d6446.tar.gz
upgrade to 1.5.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD41
2 files changed, 33 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ac7cb0357b1..1973bf9df272 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = python2-pkgconfig
pkgdesc = Python 2 module to interface with the pkg-config command line tool
- pkgver = 1.5.1
- pkgrel = 4
+ pkgver = 1.5.5
+ pkgrel = 1
url = https://github.com/matze/pkgconfig
arch = any
license = MIT
makedepends = python2-setuptools
depends = python2
- source = https://pypi.io/packages/source/p/pkgconfig/pkgconfig-1.5.1.tar.gz
- sha256sums = 97bfe3d981bab675d5ea3ef259045d7919c93897db7d3b59d4e8593cba8d354f
+ source = https://files.pythonhosted.org/packages/source/p/pkgconfig/pkgconfig-1.5.5.tar.gz
+ sha256sums = deb4163ef11f75b520d822d9505c1f462761b4309b1bb713d08689759ea8b899
pkgname = python2-pkgconfig
diff --git a/PKGBUILD b/PKGBUILD
index e12b49f6e4cf..add2a0d223b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,38 @@
-# Maintainer: Infernio <infernio at icloud dot com>
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+# Contributor: Infernio <infernio at icloud dot com>
# Contributor: Antonio Rojas <arojas@archlinux.org>
-pkgname=python2-pkgconfig
-pkgver=1.5.1
-pkgrel=4
+_py="python2"
+_pkg="pkgconfig"
+pkgname="${_py}-${_pkg}"
+pkgver=1.5.5
+pkgrel=1
pkgdesc="Python 2 module to interface with the pkg-config command line tool"
arch=(any)
-url="https://github.com/matze/pkgconfig"
+_ns="matze"
+url="https://github.com/${_ns}/${_pkg}"
license=(MIT)
-depends=(python2)
-makedepends=(python2-setuptools)
-source=("https://pypi.io/packages/source/p/pkgconfig/pkgconfig-$pkgver.tar.gz")
-sha256sums=('97bfe3d981bab675d5ea3ef259045d7919c93897db7d3b59d4e8593cba8d354f')
+depends=(
+ "${_py}"
+)
+makedepends=(
+ "${_py}-setuptools"
+)
+_pypi_url="https://files.pythonhosted.org/packages/source"
+source=(
+ "${_pypi_url}/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz"
+)
+sha256sums=(
+ 'deb4163ef11f75b520d822d9505c1f462761b4309b1bb713d08689759ea8b899'
+)
package() {
- cd pkgconfig-$pkgver
+ cd "${_pkg}-${pkgver}"
- python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ "${_py}" setup.py install --prefix=/usr \
+ --root="${pkgdir}" \
+ --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+
+# vim:set sw=2 sts=-1 et: