summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2021-01-31 15:30:47 -0500
committerTed Alff2021-01-31 15:30:47 -0500
commit3f5dde06e0eebd108a2380e850da8845820a614a (patch)
treef7620f807445ebf07797cdfc5cf041bc2c7c13c5
downloadaur-3f5dde06e0eebd108a2380e850da8845820a614a.tar.gz
Split out from python-polib PKGBUILD.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4958f7f1b6bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-polib
+ pkgdesc = A library to manipulate gettext files
+ pkgver = 1.1.0
+ pkgrel = 4
+ url = https://pypi.python.org/pypi/polib
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ source = python2-polib-1.1.0.tar.gz::https://pypi.io/packages/source/p/polib/polib-1.1.0.tar.gz
+ sha256sums = fad87d13696127ffb27ea0882d6182f1a9cf8a5e2b37a587751166c51e5a332a
+
+pkgname = python2-polib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ce185057052
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+# Contributor: Esteban V. Carnevale <alfplayer@mailoo.com>
+
+pkgbase=python2-polib
+pkgname=('python2-polib')
+_pkgname=polib
+pkgver=1.1.0
+pkgrel=4
+pkgdesc='A library to manipulate gettext files'
+url='https://pypi.python.org/pypi/polib'
+arch=('any')
+license=('MIT')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("${pkgbase}-${pkgver}.tar.gz::https://pypi.io/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('fad87d13696127ffb27ea0882d6182f1a9cf8a5e2b37a587751166c51e5a332a')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}