summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrzej Giniewicz2015-07-07 20:24:31 +0200
committerAndrzej Giniewicz2015-07-07 20:24:31 +0200
commitdc283a0f5dea97f4de73eea482e50eb05cd06014 (patch)
tree52b1a17d7867534b9db24b19af90b58d1446c238
downloadaur-dc283a0f5dea97f4de73eea482e50eb05cd06014.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..172faa177f77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-polygon
+ pkgdesc = Python package that handles polygonal shapes in 2D
+ pkgver = 2.0.7
+ pkgrel = 1
+ url = http://www.j-raedler.de/projects/polygon/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = unzip
+ depends = python2-numpy
+ options = !libtool
+ source = https://bitbucket.org/jraedler/polygon2/downloads/Polygon2-2.0.7.zip
+ md5sums = a6fa2806d75aa6e7da87f9b1b2332ecd
+
+pkgname = python2-polygon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3be2e244c97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+
+pkgname=python2-polygon
+pkgver=2.0.7
+pkgrel=1
+pkgdesc="Python package that handles polygonal shapes in 2D"
+arch=('i686' 'x86_64')
+url="http://www.j-raedler.de/projects/polygon/"
+depends=('python2-numpy')
+makedepends=('unzip')
+license=('LGPL')
+options=(!libtool)
+source=(https://bitbucket.org/jraedler/polygon2/downloads/Polygon2-${pkgver}.zip)
+md5sums=('a6fa2806d75aa6e7da87f9b1b2332ecd')
+
+build() {
+ cd "$srcdir"/Polygon2-$pkgver
+ export CFLAGS+=" -I/`python2 -c 'from distutils.sysconfig import get_python_lib; \
+ print get_python_lib()'`/numpy/core/include/"
+ export PYTHON="`which python2`"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir"/Polygon2-$pkgver
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+}
+