summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Savannah2017-06-18 01:26:54 -0400
committerTim Savannah2017-06-18 01:26:58 -0400
commit9cba1d301c3c80e6475d130b8078055a84fdcf9f (patch)
treeb277418fd111412c024fd2eaf4703f4c60e39d23
downloadaur-9cba1d301c3c80e6475d130b8078055a84fdcf9f.tar.gz
Add python2 poplines libs 2.1.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54e953dad917
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-poplines
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = http://github.com/kata198/popLines
+ arch = any
+ license = GPLv2
+ makedepends = python2-setuptools
+ makedepends = python2
+ depends = python2-setuptools
+ depends = python2
+ source = https://github.com/kata198/popLines/archive/2.1.1.tar.gz
+ sha512sums = c1d528760681132a7f9d8221e7b591d0f61d0ab1b550586712584fa1da5f11873c82fc0c38ebbd561014a980e7d11e760dbd3bb9a1a883485182561068bf03e6
+
+pkgname = python2-poplines
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22b7b039ee43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Tim Savannah <kata198@gmail.com>
+
+# Just the python2 libs for PopLines.
+# The bins are part of "poplines"
+# and depend on python-poplines (python3 libs)
+
+pkgname='python2-poplines'
+_realName=popLines
+pkgver=2.1.1
+pkgrel=1
+pkgdesc=""
+arch=('any')
+license=('GPLv2')
+url="http://github.com/kata198/popLines"
+makedepends=('python2-setuptools' 'python2')
+depends=('python2-setuptools' 'python2')
+source=("https://github.com/kata198/popLines/archive/${pkgver}.tar.gz")
+sha512sums=("c1d528760681132a7f9d8221e7b591d0f61d0ab1b550586712584fa1da5f11873c82fc0c38ebbd561014a980e7d11e760dbd3bb9a1a883485182561068bf03e6")
+
+build() {
+ cd "$srcdir/${_realName}-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "${_realName}-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ # Remove executables, they come with the "poplines" package (and depend on py3)
+ rm -Rf "${pkgdir}/usr/bin"
+}
+