summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEliot Whalan2015-06-09 12:39:29 +1000
committerEliot Whalan2015-06-09 12:39:29 +1000
commit560068cae9d5f2632e5de78c6e6fabac90390fab (patch)
treecebd61e0004b73101558c2ad447dc6cee46bfa86
downloadaur-560068cae9d5f2632e5de78c6e6fabac90390fab.tar.gz
Initial import
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
3 files changed, 74 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..67b6c0d109d3
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-potr
+ pkgdesc = This is a pure Python2 OTR implementation; it does not bind to libotr.
+ pkgver = 1.0.1
+ pkgrel = 3
+ url = https://github.com/afflux/pure-python-otr
+ arch = any
+ license = LGPL
+ depends = python2
+ depends = python2-crypto
+ conflicts = python-potr-git
+ conflicts = python-potr
+ conflicts = python2-potr-git
+ replaces = python-potr
+ source = https://github.com/afflux/pure-python-otr/tarball/1.0.1
+ sha512sums = e12823b95f166018b0aaeda8b5ca862e236d38dd165d75439ba59940001478f841cdb1e3e72f499c9222c3bb3581f4e276bcaec3e7ccb0fb026e63ed3c7ee11b
+
+pkgname = python2-potr
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67b6c0d109d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-potr
+ pkgdesc = This is a pure Python2 OTR implementation; it does not bind to libotr.
+ pkgver = 1.0.1
+ pkgrel = 3
+ url = https://github.com/afflux/pure-python-otr
+ arch = any
+ license = LGPL
+ depends = python2
+ depends = python2-crypto
+ conflicts = python-potr-git
+ conflicts = python-potr
+ conflicts = python2-potr-git
+ replaces = python-potr
+ source = https://github.com/afflux/pure-python-otr/tarball/1.0.1
+ sha512sums = e12823b95f166018b0aaeda8b5ca862e236d38dd165d75439ba59940001478f841cdb1e3e72f499c9222c3bb3581f4e276bcaec3e7ccb0fb026e63ed3c7ee11b
+
+pkgname = python2-potr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a596378b616
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Michael Duell <michael.duell@rub.de> PGP: 0xF32C939C5566FF77
+
+pkgname=python2-potr
+pkgver=1.0.1
+pkgrel=3
+pkgdesc="This is a pure Python2 OTR implementation; it does not bind to libotr."
+arch=(any)
+url="https://github.com/afflux/pure-python-otr"
+license=('LGPL')
+depends=('python2' 'python2-crypto')
+conflicts=('python-potr-git' 'python-potr' 'python2-potr-git')
+replaces=('python-potr')
+#options=(!emptydirs)
+source=("https://github.com/afflux/pure-python-otr/tarball/${pkgver}")
+
+PYTHON=`which python2`
+
+prepare() {
+ cd $srcdir/python-otr-*
+ set_python2
+}
+
+package() {
+ cd $srcdir/python-otr-*
+ $PYTHON ./setup.py install --root=$pkgdir/
+}
+
+# To use python2 instead of default python v3.
+set_python2() {
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' "${file}"
+ sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' "${file}"
+ done
+}
+
+
+# vim:set ts=2 sw=2 et:
+sha512sums=('e12823b95f166018b0aaeda8b5ca862e236d38dd165d75439ba59940001478f841cdb1e3e72f499c9222c3bb3581f4e276bcaec3e7ccb0fb026e63ed3c7ee11b')