summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormasutu2015-07-06 22:47:21 +0200
committermasutu2015-07-06 22:47:21 +0200
commit2f09736ef139160f152ec589d9573ec9e5f919e0 (patch)
treededdb01255b2801c3501c4785e98e7bd3311c1c6
downloadaur-2f09736ef139160f152ec589d9573ec9e5f919e0.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce3821f42057
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-powerlaw
+ pkgdesc = Toolbox for testing if a probability distribution fits a power law
+ pkgver = 1.3.4
+ pkgrel = 1
+ url = https://github.com/jeffalstott/powerlaw
+ arch = any
+ license = GPL
+ depends = python2-scipy
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/p/powerlaw/powerlaw-1.3.4.tar.gz
+ md5sums = a5de54dafdb1e7b314a6bd260a1d56a7
+
+pkgname = python2-powerlaw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84249532baaa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: masutu Subric <masutu dot arch at gmail dot com>
+# Contributor: masutu Subric <masutu dot arch at gmail dot com>
+pkgname=python2-powerlaw
+_module_name=powerlaw
+pkgver=1.3.4
+pkgrel=1
+pkgdesc="Toolbox for testing if a probability distribution fits a power law"
+arch=(any)
+url="https://github.com/jeffalstott/powerlaw"
+license=('GPL')
+depends=('python2-scipy')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/p/${_module_name}/${_module_name}-${pkgver}.tar.gz")
+md5sums=('a5de54dafdb1e7b314a6bd260a1d56a7')
+
+package() {
+ cd "$srcdir/${_module_name}-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: