summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexej Grigorjew2017-05-17 15:59:08 +0200
committerAlexej Grigorjew2017-05-17 15:59:08 +0200
commit0c3bf5b206a2c9a836b740c8300b61c38b128f8c (patch)
tree56f7192508e2a17528157a1b1b2e46503b438755
downloadaur-0c3bf5b206a2c9a836b740c8300b61c38b128f8c.tar.gz
initial commit (only pkgbuild and srcinfo)
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33dd676710bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-pptx
+ pkgdesc = Python library for creating and updating PowerPoint (.pptx) files
+ pkgver = 0.6.5
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/python-pptx
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-pillow
+ depends = python2-lxml
+ depends = python2-xlsxwriter
+ source = https://pypi.python.org/packages/f8/9c/30bc244cedc571307efe0780d8195ffed5b08f09c94d23f50d6d5144ebc7/python-pptx-0.6.5.tar.gz
+ sha256sums = 67926906d088e28f6ad2174f1c6512c4a3507aa9cc2b252cb2fa9698b0588c86
+
+pkgname = python2-pptx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e90ac8936f68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Alexej Grigorjew <alexg91 at gmx dot de>
+# Maintainer: Alexej Grigorjew <alexg91 at gmx dot de>
+
+pkgname=python2-pptx
+pkgver=0.6.5
+pkgrel=1
+pkgdesc="Python library for creating and updating PowerPoint (.pptx) files"
+arch=('any')
+url="https://pypi.python.org/pypi/python-pptx"
+license=('MIT')
+depends=('python2' 'python2-pillow' 'python2-lxml' 'python2-xlsxwriter')
+makedepends=('python2-setuptools')
+source=(https://pypi.python.org/packages/f8/9c/30bc244cedc571307efe0780d8195ffed5b08f09c94d23f50d6d5144ebc7/python-pptx-$pkgver.tar.gz)
+
+package() {
+ cd "$srcdir/python-pptx-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+sha256sums=('67926906d088e28f6ad2174f1c6512c4a3507aa9cc2b252cb2fa9698b0588c86')