summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJurica Bradarić2015-06-16 14:47:34 +0000
committerJurica Bradarić2015-06-16 14:47:34 +0000
commit82d7de7cb70dbaeb2bc46ac17b2178e2a61f7c78 (patch)
tree7884bf62503b8bdb2e643f1706ab50685c0a3f2a
downloadaur-82d7de7cb70dbaeb2bc46ac17b2178e2a61f7c78.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE15
-rw-r--r--PKGBUILD26
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9815e45bc8ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-profilehooks
+ pkgdesc = Decorators for profiling/timing/tracing individual functions
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = http://mg.pov.lt/profilehooks
+ arch = any
+ license = custom:MIT
+ makedepends = python2
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://pypi.python.org/packages/source/p/profilehooks/profilehooks-1.8.0.tar.gz
+ source = LICENSE
+ sha256sums = 52277ed965938d8b6293aa41cb35278c72c9a6dd3f6e9f89c45da74767dbd6ea
+ sha256sums = 782297002c4e5baa591d289916113b39d8ae046e41855e6beb1266f26f9ec82a
+
+pkgname = python2-profilehooks
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..def38db25a54
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,15 @@
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d8a4928c97f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jurica Bradaric <jbradaric@gmail.com>
+pkgname=python2-profilehooks
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="Decorators for profiling/timing/tracing individual functions"
+arch=(any)
+url="http://mg.pov.lt/profilehooks"
+license=('custom:MIT')
+depends=('python2')
+makedepends=('python2' 'python2-setuptools')
+
+source=("https://pypi.python.org/packages/source/p/profilehooks/profilehooks-1.8.0.tar.gz"
+ "LICENSE")
+sha256sums=('52277ed965938d8b6293aa41cb35278c72c9a6dd3f6e9f89c45da74767dbd6ea'
+ '782297002c4e5baa591d289916113b39d8ae046e41855e6beb1266f26f9ec82a')
+
+build() {
+ cd "${srcdir}/profilehooks-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/profilehooks-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}