summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Meusel2015-10-25 12:19:30 +0100
committerTim Meusel2015-10-25 12:36:01 +0100
commitd80b9731708a7686ab373dbc6fea7dafbc911d22 (patch)
tree567f317fe78cf1d294706ccfc112df594448eb5e
downloadaur-d80b9731708a7686ab373dbc6fea7dafbc911d22.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
-rw-r--r--puppetboard.install18
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e0130b70ad3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python2-puppetboard
+ pkgdesc = Web frontend for PuppetDB which relies on pypuppetdb
+ pkgver = 0.0.5
+ pkgrel = 1
+ url = https://github.com/puppet-community/puppetboard
+ install = puppetboard.install
+ arch = any
+ license = APACHE
+ depends = python2
+ depends = python2-flask
+ depends = python2-flask-wtf
+ depends = python2-jinja
+ depends = python2-markupsafe
+ depends = python2-wtforms
+ depends = python2-werkzeug
+ depends = python2-itsdangerous
+ depends = python2-requests
+ depends = python2-pypuppetdb
+ source = https://github.com/puppet-community/puppetboard/archive/v0.0.5.tar.gz
+ sha512sums = f91c1eec66a13ecc59aaf2eb1d6fb7e102a1b23a2fbb5660f0f59f98f873d6c8c957f162665c6e8d52b65e801e2f6c558536f57c129cb59d8c2ed525d5ea2169
+
+pkgname = python2-puppetboard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a10fbb1c6293
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Puppetdb: Installer: Arch
+# Original Author: Niels Abspoel <aboe76 (at) Gmail (dot) com>
+# Maintainer: Tim Meusel <tim@bastelfreak.de>
+# Contributor Florian Pritz <bluewind@xinu.at>
+
+pkgname=python2-puppetboard
+pkgver=0.0.5
+pkgrel=1
+pkgdesc='Web frontend for PuppetDB which relies on pypuppetdb'
+arch=(any)
+url='https://github.com/puppet-community/puppetboard'
+license=('APACHE')
+depends=('python2'
+ 'python2-flask'
+ 'python2-flask-wtf'
+ 'python2-jinja'
+ 'python2-markupsafe'
+ 'python2-wtforms'
+ 'python2-werkzeug'
+ 'python2-itsdangerous'
+ 'python2-requests'
+ 'python2-pypuppetdb')
+
+install=puppetboard.install
+source=("https://github.com/puppet-community/puppetboard/archive/v${pkgver}.tar.gz")
+sha512sums=('f91c1eec66a13ecc59aaf2eb1d6fb7e102a1b23a2fbb5660f0f59f98f873d6c8c957f162665c6e8d52b65e801e2f6c558536f57c129cb59d8c2ed525d5ea2169')
+
+package() {
+ cd "${srcdir}/puppetboard-${pkgver}"
+ python2 setup.py install --root=${pkgdir}/ --optimize=1
+}
diff --git a/puppetboard.install b/puppetboard.install
new file mode 100644
index 000000000000..fbea38c50906
--- /dev/null
+++ b/puppetboard.install
@@ -0,0 +1,18 @@
+# Original Author: Niels Abspoel <aboe76 (at) Gmail (dot) com>
+# Maintainer: Tim Meusel <tim@bastelfreak.de>
+
+post_install() {
+ echo ""
+ echo "========================================"
+ echo ""
+ echo "This will only install puppetboard read:"
+ echo "https://github.com/nedap/puppetboard"
+ echo "on how to configure"
+ echo ""
+ echo "========================================"
+}
+
+post_upgrade () {
+ post_install
+}
+# vim:set ts=2 sw=2 et: