summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjerry732042016-09-04 00:17:10 +0800
committerjerry732042016-09-04 00:17:10 +0800
commit8114ab85df7d81c5d718e32fe199585679801da9 (patch)
tree7a2fbacbaa366d995c2feee54bf3a9914d5cfc17
parent961c2e4cf1b609b8a60d472ff85a406ee66510bd (diff)
downloadaur-8114ab85df7d81c5d718e32fe199585679801da9.tar.gz
Updated to 3.0.1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
-rw-r--r--remove-argparse.patch12
3 files changed, 18 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dfa7269e532..51bfc6619ae5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Mon Jul 4 10:29:04 UTC 2016
+# Sat Sep 3 16:16:43 UTC 2016
pkgbase = python2-pwntools
pkgdesc = The CTF framework used by Gallopsled in every CTF
- pkgver = 2.3.0
+ pkgver = 3.0.1
pkgrel = 1
- url = https://github.com/Gallopsled/pwntools/
+ url = https://pwntools.com/
arch = any
license = MIT
license = GPL2
@@ -19,14 +19,16 @@ pkgbase = python2-pwntools
depends = python2-pyserial
depends = python2-requests
depends = python2-psutil
+ depends = python2-tox
+ depends = python2-pysocks
+ depends = python2-dateutil
+ depends = python2-pygments
depends = ropgadget
conflicts = python2-pwntools
conflicts = python2-pwntools-git
options = strip
- source = https://github.com/Gallopsled/pwntools/archive/2.3.0.tar.gz
- source = remove-argparse.patch
- sha1sums = bb15fb7365093e1ddc7417896843e5e3868bec72
- sha1sums = 42ba67adb748fdc31a95ecb108814ca33eee5c36
+ source = https://github.com/Gallopsled/pwntools/archive/3.0.1.tar.gz
+ sha1sums = 13ea6800d45738f322f58578f1dbb2c1a9886e33
pkgname = python2-pwntools
diff --git a/PKGBUILD b/PKGBUILD
index 9f39a27e2964..b8e8290d1913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: jerry73204 <jerry73204@gmail.com>
pkgname=python2-pwntools
-pkgver=2.3.0
+pkgver=3.0.1
pkgrel=1
pkgdesc='The CTF framework used by Gallopsled in every CTF'
arch=('any')
-url='https://github.com/Gallopsled/pwntools/'
+url='https://pwntools.com/'
license=('MIT' 'GPL2' 'BSD')
makedepends=('lib32-glibc'
'python2-setuptools')
@@ -16,19 +16,21 @@ depends=('python2>=2.7'
'python2-pyserial'
'python2-requests'
'python2-psutil'
+ 'python2-tox'
+ 'python2-pysocks'
+ 'python2-dateutil'
+ 'python2-pygments'
'ropgadget')
conflicts=('python2-pwntools' 'python2-pwntools-git')
options=('strip')
-source=("https://github.com/Gallopsled/pwntools/archive/${pkgver}.tar.gz"
- 'remove-argparse.patch')
-sha1sums=('bb15fb7365093e1ddc7417896843e5e3868bec72'
- '42ba67adb748fdc31a95ecb108814ca33eee5c36')
+source=("https://github.com/Gallopsled/pwntools/archive/${pkgver}.tar.gz")
+sha1sums=('13ea6800d45738f322f58578f1dbb2c1a9886e33')
_repodir="pwntools-${pkgver}"
prepare() {
cd "${srcdir}/${_repodir}"
- patch -Np1 < "${srcdir}/remove-argparse.patch"
+ # patch -Np1 < "${srcdir}/remove-argparse.patch"
}
package() {
diff --git a/remove-argparse.patch b/remove-argparse.patch
deleted file mode 100644
index 94db50cd5de8..000000000000
--- a/remove-argparse.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/setup.py b/setup.py
-index fed5c02..cf075b7 100644
---- a/setup.py
-+++ b/setup.py
-@@ -33,7 +33,6 @@ for filename in glob.glob('pwnlib/commandline/*'):
- console_scripts.append(script)
-
- install_requires = ['paramiko>=1.15.2',
-- 'argparse',
- 'mako>=1.0.0',
- 'pyelftools>=0.2.3',
- 'capstone',