summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZyg0te2015-06-10 08:49:46 +0200
committerZyg0te2015-06-10 08:49:46 +0200
commit1b1dc08a16a8a1c51cbd2f0f40fe5c9ae5520f3b (patch)
tree018f2ee0d6fb607956308b24c3888b94ec54e225
downloadaur-1b1dc08a16a8a1c51cbd2f0f40fe5c9ae5520f3b.tar.gz
Initial import of python2-pyand-git to AUR4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d50fa422331
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-pyand-git
+ pkgdesc = A Python wrapper library for ADB and Fastboot
+ pkgver = r54.f90701b
+ pkgrel = 1
+ url = https://github.com/Zyg0te/pyand
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2
+ source = python2-pyand-git::git+https://github.com/Zyg0te/pyand.git
+ md5sums = SKIP
+
+pkgname = python2-pyand-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f71e084e538
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Edvard Holst <edvard.holst at gmail>
+
+pkgname=python2-pyand-git
+pkgver=r54.f90701b
+pkgrel=1
+pkgdesc="A Python wrapper library for ADB and Fastboot"
+arch=('any')
+url="https://github.com/Zyg0te/pyand"
+license=('MIT')
+depends=('python2')
+makedepends=('git' 'python2-setuptools')
+# The git repo is detected by the 'git:' or 'git+' beginning. The branch
+# '$pkgname' is then checked out upon cloning, expediating versioning:
+source=($pkgname::git+'https://github.com/Zyg0te/pyand.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the tag of the last commit
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ export PYTHONPATH="$pkgdir/usr/lib/python2.7/site-packages"
+ cd "$srcdir/"
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m755 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/"
+ mkdir -p "$pkgdir/usr/lib/python2.7/site-packages"
+ easy_install-2.7 --prefix "$pkgdir/usr" python2-pyand-git
+}