summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMunzir Taha2017-01-01 02:01:38 +0300
committerMunzir Taha2017-01-01 02:01:38 +0300
commit97fc1671ac85b8d03f90c2fba2696f548a970707 (patch)
tree5947053b496e9e24a60a0ee017c17d2e09c4a995
downloadaur-97fc1671ac85b8d03f90c2fba2696f548a970707.tar.gz
Initial Commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16a713205b2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-pyarabic
+ pkgdesc = Arabic text tools for Python
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/linuxscout/pyarabic
+ arch = any
+ license = GPL
+ depends = python2
+ source = https://github.com/linuxscout/pyarabic/archive/master.zip
+ sha256sums = ef7c12ba38ad79c346d98fa51f3a5f20539cc59f54496a21122ec1d7d9a4f11c
+
+pkgname = python2-pyarabic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..047e41b89ab9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Munzir Taha <munzirtaha@gmail.com>
+pkgname=python2-pyarabic
+pkgver=0.4
+pkgrel=1
+pkgdesc="Arabic text tools for Python"
+arch=('any')
+url="https://github.com/linuxscout/pyarabic"
+license=('GPL')
+depends=('python2')
+source=("$url/archive/master.zip")
+sha256sums=('ef7c12ba38ad79c346d98fa51f3a5f20539cc59f54496a21122ec1d7d9a4f11c')
+
+package() {
+ # FIXME: cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/pyarabic-master"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ install -d $pkgdir/usr/share/doc/$pkgname
+ install -m644 README.md "$pkgdir/usr/share/doc/$pkgname/"
+}