summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-02-25 14:00:58 -0500
committerCarlos Aznarán Laos2022-02-25 14:00:58 -0500
commit64a1fe5317d135a70cf3c224eae37c9bb9b5e9e3 (patch)
tree82c27a6b48424299a630f6f3043cbe6a12995949
parente44a0861d995ffd473f217bd909beadbc5376663 (diff)
downloadaur-python2-pyassimp.tar.gz
Version bump to 5.2.2
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD33
3 files changed, 24 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7597d6169b5..dda39640ba7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python2-pyassimp
- pkgdesc = Portable Open Source library to import various well-known 3D model formats in an uniform manner. Python bindings.
- pkgver = 3.1.1
+ pkgdesc = Python bindings for the Open Asset Import Library (ASSIMP)
+ pkgver = 5.2.2
pkgrel = 1
- url = http://assimp.sourceforge.net/index.html
- arch = i686
- arch = x86_64
- license = BSD
+ url = https://github.com/assimp/assimp
+ arch = any
+ license = custom
+ makedepends = python2-setuptools
depends = assimp
depends = python2
- source = https://github.com/assimp/assimp/archive/v3.1.1.tar.gz
- md5sums = ab9977edf95e9b2910d7cca286926e85
+ source = https://github.com/assimp/assimp/archive/v5.2.2.tar.gz
+ sha512sums = 7f11f3e53bdcd43a81be49ce2ad90d97769ae1c3c6157f57e8a0b2b41c72f394ad1afcdc5f5fa6fbfa1a44233fed4b9a578d5548ec5b9aae2113ef88c2ec843a
pkgname = python2-pyassimp
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 71f729104e33..b3493db38d38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,23 @@
-# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: jepaan <jepaan at hotmail dot com>
-
-pkgname=python2-pyassimp
-_name=assimp
-pkgver=3.1.1
+_base=assimp
+pkgname=python2-py${_base}
+pkgver=5.2.2
pkgrel=1
-pkgdesc="Portable Open Source library to import various well-known 3D model formats in an uniform manner. Python bindings."
-arch=('i686' 'x86_64')
-license=('BSD')
-depends=('assimp' 'python2')
-url=('http://assimp.sourceforge.net/index.html')
-source=("https://github.com/assimp/assimp/archive/v${pkgver}.tar.gz")
-md5sums=('ab9977edf95e9b2910d7cca286926e85')
+pkgdesc="Python bindings for the Open Asset Import Library (ASSIMP)"
+arch=(any)
+license=('custom')
+depends=(assimp python2)
+makedepends=(python2-setuptools)
+url="https://github.com/${_base}/${_base}"
+source=(${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('7f11f3e53bdcd43a81be49ce2ad90d97769ae1c3c6157f57e8a0b2b41c72f394ad1afcdc5f5fa6fbfa1a44233fed4b9a578d5548ec5b9aae2113ef88c2ec843a')
-build()
-{
- cd ${srcdir}/${_name}-${pkgver}/port/PyAssimp
+build() {
+ cd ${_base}-${pkgver}/port/PyAssimp
python2 setup.py build
}
-package()
-{
- cd ${srcdir}/${_name}-${pkgver}/port/PyAssimp
+package() {
+ cd ${_base}-${pkgver}/port/PyAssimp
python2 setup.py install --root="$pkgdir/" --optimize=1
}