summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-03-25 22:42:39 +0100
committerBenjamin Chrétien2014-03-25 22:42:39 +0100
commite5f18c06ed7bfe7ec7b37c8e1e6b4f983ebb0a71 (patch)
tree8da711e8efa6000100e049f5b97b925ef4a8641f
downloadaur-e5f18c06ed7bfe7ec7b37c8e1e6b4f983ebb0a71.tar.gz
Update pybindgen.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4fbc2a5813f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-pybindgen
+ pkgdesc = A tool to generate Python bindings for C/C++ code
+ pkgver = 0.17.0
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/PyBindGen
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = waf
+ depends = python2
+ depends = pygccxml
+ provides = python2-pybindgen
+ conflicts = python2-pybindgen-bzr
+ source = https://pypi.python.org/packages/source/P/PyBindGen/PyBindGen-0.17.0.tar.gz
+ md5sums = 7d8fe2b3b4646c3c1d9e5342b1645f6a
+
+pkgname = python2-pybindgen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..470b082e4a01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
+# Contributor: Sebastien Binet <binet@lblbox>
+pkgname=python2-pybindgen
+pkgver=0.17.0
+pkgrel=1
+pkgdesc="A tool to generate Python bindings for C/C++ code"
+url="http://pypi.python.org/pypi/PyBindGen"
+arch=('i686' 'x86_64')
+license=('LGPL')
+depends=('python2' 'pygccxml')
+makedepends=('waf')
+provides=('python2-pybindgen')
+conflicts=('python2-pybindgen-bzr')
+source=("https://pypi.python.org/packages/source/P/PyBindGen/PyBindGen-${pkgver}.tar.gz")
+md5sums=('7d8fe2b3b4646c3c1d9e5342b1645f6a')
+
+build() {
+ cd ${srcdir}/PyBindGen-$pkgver
+ PYTHON=python2 ./waf configure --prefix=/usr
+ PYTHON=python2 ./waf
+}
+
+check() {
+ cd ${srcdir}/PyBindGen-$pkgver
+ PYTHON=python2 ./waf check
+}
+
+package() {
+ cd ${srcdir}/PyBindGen-$pkgver
+ PYTHON=python2 ./waf install --prefix=/usr --destdir=${pkgdir}
+}