summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-03-27 15:20:02 +0200
committerMartino Pilia2018-03-27 15:20:02 +0200
commit9d4a1846d60bc14e50873c33b7c1f5e9ab62e27a (patch)
tree78b28e21e98a3bb2dae5a1a866a6c1a2bff5aa0b
parentc45ac9230e4077842afec78badc1e429d731d565 (diff)
downloadaur-python2-pyca-git.tar.gz
fix a small bug, remove Python 3 headers also from CUDA includes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fab1e3b5324..b26d0349186a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-pyca-git
pkgdesc = Python for Computational Anatomy
pkgver = 0.01.r434.gf31ab43
- pkgrel = 10
+ pkgrel = 11
url = http://bitbucket.org/scicompanat/pyca
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index c781b1746e67..a1ef4ff3b1a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=pyca
pkgname=python2-pyca-git
pkgver=0.01.r434.gf31ab43
-pkgrel=10
+pkgrel=11
pkgdesc="Python for Computational Anatomy"
arch=('x86_64')
url="http://bitbucket.org/scicompanat/pyca"
@@ -37,7 +37,7 @@ prepare() {
sed -i 's/<< std::cout <</<</g' "$srcdir/$_name/Code/Cxx/src/alg/MultiscaleManager.cxx"
# Cuda requires a specific version of gcc
- if [ "" != "`pacman -Qi cuda 2&>/dev/null | grep 'Version'`" ]; then
+ if [ "" != "`pacman -Qi cuda 2>/dev/null | grep 'Version'`" ]; then
_cc="/opt/cuda/bin/gcc"
_use_cuda="ON"
else
@@ -67,6 +67,16 @@ prepare() {
build() {
cd "$srcdir/$_name/build"
make
+
+ if [ "$_use_cuda" == "ON" ]; then
+ make CUDA_TPL_DEPS
+
+ # Do not include Python 3 stuff
+ for f in `grep -nr . | grep 'python3\.6' | cut -f1 -d':'`
+ do
+ sed -i 's/[^ ;]\+python3\.[^ ;]\+//g' $f
+ done
+ fi
}
package() {