summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroslik2016-06-25 12:13:38 +0300
committeroslik2016-06-25 12:13:38 +0300
commit12fe181b53301cfe8b34cf1ea5a75db17b3f4f88 (patch)
tree37b925d5b440a8abdb85d28564c37a9d2fb36bee
downloadaur-12fe181b53301cfe8b34cf1ea5a75db17b3f4f88.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3ca4312ab8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-pycallgraph
+ pkgdesc = Python module that creates call graph visualizations for Python applications.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://pycallgraph.slowchop.com/
+ arch = any
+ license = GPLv2
+ depends = python
+ depends = python-setuptools
+ depends = python2-pygraphviz
+ source = https://github.com/gak/pycallgraph/archive/1.0.1.tar.gz
+ md5sums = b74aa0bb84f53e5d241f5dc16a83f143
+
+pkgname = python2-pycallgraph
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ef004abd69b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+_name=pycallgraph
+pkgname=python2-$_name
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Python module that creates call graph visualizations for Python applications."
+arch=('any')
+url="http://pycallgraph.slowchop.com/"
+license=('GPLv2')
+depends=('python' 'python-setuptools' 'python2-pygraphviz')
+source=("https://github.com/gak/$_name/archive/$pkgver.tar.gz")
+md5sums=('b74aa0bb84f53e5d241f5dc16a83f143')
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}
+# vim:set ts=2 sw=2 et: