summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2014-10-18 01:47:10 -0400
committermutantmonkey2014-10-18 01:47:10 -0400
commitbdf84d5d9f1a0063a999454c2c8aec9d6243e6c8 (patch)
tree81f5e95d4441ba68b9609e84b94d3148964640a9
downloadaur-bdf84d5d9f1a0063a999454c2c8aec9d6243e6c8.tar.gz
add python2-pychromecast-git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88e58c39a593
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-pychromecast-git
+ pkgdesc = Library for Python 2 and 3 to communicate with the Google Chromecast.
+ pkgver = 88.702017d
+ pkgrel = 1
+ url = https://github.com/balloob/pychromecast
+ arch = any
+ license = MIT
+ depends = python2>=2.7
+ depends = python2-requests
+ depends = python2-protobuf
+ provides = python2-pychromecast
+ conflicts = python2-pychromecast
+ options = !emptydirs
+ source = git+https://github.com/balloob/pychromecast.git
+ sha256sums = SKIP
+
+pkgname = python2-pychromecast-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25f9b542b47a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+pkgname=python2-pychromecast-git
+pkgver=88.702017d
+pkgrel=1
+pkgdesc="Library for Python 2 and 3 to communicate with the Google Chromecast."
+arch=('any')
+url="https://github.com/balloob/pychromecast"
+license=('MIT')
+depends=('python2>=2.7' 'python2-requests' 'python2-protobuf')
+provides=('python2-pychromecast')
+conflicts=('python2-pychromecast')
+options=(!emptydirs)
+source=('git+https://github.com/balloob/pychromecast.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pychromecast"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir/pychromecast"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: