summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2019-07-22 09:15:23 -0700
committerDonald Webster2019-07-22 09:15:23 -0700
commit574d1131f6e2b3fb7b943116f13382d03abcc6a1 (patch)
treeec827e99af871e6bc6b2bc8f3abf7f4a13974781
parenta45ae5235dccbc02f54c608e9e908f600eed8009 (diff)
downloadaur-574d1131f6e2b3fb7b943116f13382d03abcc6a1.tar.gz
Clean up PKGBUILD.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d57e030593b2..a0c80d80b2b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = python2-pycountry
checkdepends = python2-pytest-runner
makedepends = python2
makedepends = python2-setuptools
- source = https://pypi.io/packages/source/p/pycountry/pycountry-19.7.15.tar.gz
+ source = https://files.pythonhosted.org/packages/source/p/pycountry/pycountry-19.7.15.tar.gz
sha512sums = 504ddf66747817a0bf7f9420e541c5589e3dacf818095af0b9de7ffdb66040345445900009349d5564647d33ec6941090aadbdc5931160314f621935d2556d99
pkgname = python2-pycountry
diff --git a/PKGBUILD b/PKGBUILD
index 35f7192a42df..40f74b0b2736 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,6 +4,7 @@
# Contributor: Pawel "kTT" Salata <rockplayer.pl@gmail.com>
pkgname=('python2-pycountry')
+_name=${pkgname#python2-}
pkgver=19.7.15
pkgrel=1
pkgdesc="ISO country, subdivision, language, currency and script definitions and their translations"
@@ -12,7 +13,7 @@ url="https://pypi.org/project/pycountry/"
license=('LGPL2.1')
makedepends=('python2' 'python2-setuptools')
checkdepends=('python2-pytest' 'python2-pytest-runner')
-source=("https://pypi.io/packages/source/p/pycountry/pycountry-${pkgver}.tar.gz")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
sha512sums=('504ddf66747817a0bf7f9420e541c5589e3dacf818095af0b9de7ffdb66040345445900009349d5564647d33ec6941090aadbdc5931160314f621935d2556d99')
build(){
@@ -25,9 +26,9 @@ check(){
python2 setup.py pytest
}
-
package_python2-pycountry() {
- depends=('python2' 'python2-lxml')
+ depends=('python2'
+ 'python2-lxml')
cd "${srcdir}/pycountry-${pkgver}"
python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}