summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2019-03-11 09:13:46 -0700
committerDonald Webster2019-03-11 09:13:46 -0700
commitc639d9b777fc86b68e98f1335d363e4ea23650b1 (patch)
tree4d46451eba54d54bea67f50cfbdd18955b9f076a
downloadaur-c639d9b777fc86b68e98f1335d363e4ea23650b1.tar.gz
Restore python2-pycountry using original package.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b21dda756301
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-pycountry
+ pkgdesc = ISO country, subdivision, language, currency and script definitions and their translations
+ pkgver = 18.12.8
+ pkgrel = 2
+ url = https://pypi.org/project/pycountry/
+ arch = any
+ license = LGPL2.1
+ checkdepends = python2-pytest
+ checkdepends = python2-pytest-runner
+ makedepends = python2
+ makedepends = python2-setuptools
+ source = https://pypi.io/packages/source/p/pycountry/pycountry-18.12.8.tar.gz
+ sha512sums = 9797688ada8ea54c1a56a2cf4d0ad765001816c822c40077953fa71e3af285114c4b5beaf739a24432b9c6ea794952ce347a40ae0bcd9a2c00d12ddc7b45261e
+
+pkgname = python2-pycountry
+ depends = python2
+ depends = python2-lxml
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..97484cf0bb87
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.xz
+/*.gz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4bb43b774a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Donald Webster <fryfrog@gmail.com>
+# Contributor: Morten Linderud <foxboron@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Pawel "kTT" Salata <rockplayer.pl@gmail.com>
+
+pkgname=('python2-pycountry')
+pkgver=18.12.8
+pkgrel=2
+pkgdesc="ISO country, subdivision, language, currency and script definitions and their translations"
+arch=('any')
+url="https://pypi.org/project/pycountry/"
+license=('LGPL2.1')
+makedepends=('python2' 'python2-setuptools')
+checkdepends=('python2-pytest' 'python2-pytest-runner')
+source=("https://pypi.io/packages/source/p/pycountry/pycountry-${pkgver}.tar.gz")
+sha512sums=('9797688ada8ea54c1a56a2cf4d0ad765001816c822c40077953fa71e3af285114c4b5beaf739a24432b9c6ea794952ce347a40ae0bcd9a2c00d12ddc7b45261e')
+
+build(){
+ cd "${srcdir}/pycountry-${pkgver}"
+ python2 setup.py build
+}
+
+check(){
+ cd "${srcdir}/pycountry-${pkgver}"
+ python2 setup.py pytest
+}
+
+
+package_python2-pycountry() {
+ depends=('python2' 'python2-lxml')
+ cd "${srcdir}/pycountry-${pkgver}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}