summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Schlatow2020-09-08 10:18:50 +0200
committerJohannes Schlatow2020-09-08 10:19:15 +0200
commit27989635c9da2cfe2ec676da93c83368c62671d0 (patch)
tree627571b665f48e43f4f8355d8306ea0e13a63709
downloadaur-27989635c9da2cfe2ec676da93c83368c62671d0.tar.gz
initial version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03aaa18b4db2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python2-pycpa-git
+ pkgdesc = Pragmatic Python implementation of Compositional Performance Analysis (aka the SymTA/S approach provided by Symtavision) used for research in worst-case timing analysis.
+ pkgver = 20200908
+ pkgrel = 1
+ url = https://bitbucket.org/pycpa/pycpa/
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python2
+ depends = python2-matplotlib
+ depends = simpy
+ depends = python2-setuptools
+ depends = python2-nose
+ depends = python2-tornado
+ provides = python2-pycpa
+ source = git+https://bitbucket.org/pycpa/pycpa
+ md5sums = SKIP
+
+pkgname = python2-pycpa-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd7e3bf45ab2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Johannes Schlatow <johannes.schlatow@googlemail.com>
+
+_pkgname=python2-pycpa
+pkgname=$_pkgname-git
+pkgver=20200908
+pkgrel=1
+pkgdesc="Pragmatic Python implementation of Compositional Performance Analysis (aka the SymTA/S approach provided by Symtavision) used for research in worst-case timing analysis."
+arch=('any')
+makedepends=('git')
+depends=('python2' 'python2-matplotlib' 'simpy' 'python2-setuptools' 'python2-nose' 'python2-tornado')
+provides=('python2-pycpa')
+replaces=('python2-pycpa-git')
+url="https://bitbucket.org/pycpa/pycpa/"
+license=('MIT')
+
+source=("git+https://bitbucket.org/pycpa/pycpa")
+md5sums=("SKIP")
+
+build() {
+ cd ${srcdir}/pycpa
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/pycpa
+ python2 setup.py install --root="${pkgdir}"
+}