summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Schlatow2020-09-09 09:04:25 +0200
committerJohannes Schlatow2020-09-09 09:04:25 +0200
commitb28319e34695d57b57f7418d03a4d95050e96dd7 (patch)
tree4944d0e0260a965e09288638e6b94928d85092e1
parent27989635c9da2cfe2ec676da93c83368c62671d0 (diff)
downloadaur-b28319e34695d57b57f7418d03a4d95050e96dd7.tar.gz
install LICENSE
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03aaa18b4db2..ad9362eea4dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-pycpa-git
pkgdesc = Pragmatic Python implementation of Compositional Performance Analysis (aka the SymTA/S approach provided by Symtavision) used for research in worst-case timing analysis.
- pkgver = 20200908
+ pkgver = 20200909
pkgrel = 1
url = https://bitbucket.org/pycpa/pycpa/
arch = any
@@ -13,6 +13,7 @@ pkgbase = python2-pycpa-git
depends = python2-nose
depends = python2-tornado
provides = python2-pycpa
+ replaces = python2-pycpa-git
source = git+https://bitbucket.org/pycpa/pycpa
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index dd7e3bf45ab2..6539a739229b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=python2-pycpa
pkgname=$_pkgname-git
-pkgver=20200908
+pkgver=20200909
pkgrel=1
pkgdesc="Pragmatic Python implementation of Compositional Performance Analysis (aka the SymTA/S approach provided by Symtavision) used for research in worst-case timing analysis."
arch=('any')
@@ -24,4 +24,6 @@ build() {
package() {
cd ${srcdir}/pycpa
python2 setup.py install --root="${pkgdir}"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}