summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Schlatow2015-06-20 17:59:33 +0200
committerJohannes Schlatow2015-06-20 17:59:33 +0200
commit46f40c4e54f7b27cd5d5fbcfb15f7ba1bfb518fd (patch)
tree61c6e1293e8ee09e2cb5f5e5c32652490c5c70c9
downloadaur-46f40c4e54f7b27cd5d5fbcfb15f7ba1bfb518fd.tar.gz
migrate to AUR4
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD26
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b7350fad80d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by makepkg 4.2.1
+# Tue Mar 17 13:11:24 UTC 2015
+pkgbase = python2-pycpa-hg
+ pkgdesc = Pragmatic Python implementation of Compositional Performance Analysis (aka the SymTA/S approach provided by Symtavision) used for research in worst-case timing analysis.
+ pkgver = 20150317
+ pkgrel = 1
+ url = https://bitbucket.org/pycpa/pycpa/
+ arch = any
+ license = MIT
+ makedepends = mercurial
+ depends = python2
+ depends = python2-matplotlib
+ depends = python2-pygraphviz
+ depends = simpy
+ depends = python2-setuptools
+ depends = python2-nose
+ depends = python2-tornado
+ provides = python2-pycpa
+ source = hg+https://bitbucket.org/pycpa/pycpa
+ md5sums = SKIP
+
+pkgname = python2-pycpa-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6ca38dd80c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Johannes Schlatow <johannes.schlatow@googlemail.com>
+
+_pkgname=python2-pycpa
+pkgname=$_pkgname-hg
+pkgver=20150317
+pkgrel=1
+pkgdesc="Pragmatic Python implementation of Compositional Performance Analysis (aka the SymTA/S approach provided by Symtavision) used for research in worst-case timing analysis."
+arch=('any')
+makedepends=('mercurial')
+depends=('python2' 'python2-matplotlib' 'python2-pygraphviz' 'simpy' 'python2-setuptools' 'python2-nose' 'python2-tornado')
+provides=('python2-pycpa')
+url="https://bitbucket.org/pycpa/pycpa/"
+license=('MIT')
+
+source=("hg+https://bitbucket.org/pycpa/pycpa")
+md5sums=("SKIP")
+
+build() {
+ cd ${srcdir}/pycpa
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/pycpa
+ python2 setup.py install --root="${pkgdir}"
+}