summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2016-10-15 23:36:38 -0400
committerDrew DeVault2016-10-15 23:36:38 -0400
commite2159b6bf6d3f67cfa65bccd8545b0bd9bd88c59 (patch)
treefef06e113e5d823dcce219a72291e5c56ff69919
downloadaur-e2159b6bf6d3f67cfa65bccd8545b0bd9bd88c59.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9abc8184ee8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Oct 16 03:36:36 UTC 2016
+pkgbase = python-pycrypto
+ pkgdesc = Cryptographic primitives and algorithms for Python
+ pkgver = 2.6.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/pycrypto
+ arch = any
+ license = Public domain
+ makedepends = python-distribute
+ depends = python-flask
+ source = http://pypi.python.org/packages/source/p/pycrypto/pycrypto-2.6.1.tar.gz
+ md5sums = 55a61a054aa66812daf5161a0d5d7eda
+
+pkgname = python-pycrypto
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0a2223f3641d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05b41b3d6163
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+
+pkgname='python-pycrypto'
+pkgver=2.6.1
+pkgrel=1
+pkgdesc='Cryptographic primitives and algorithms for Python'
+arch=('any')
+url='https://pypi.python.org/pypi/pycrypto'
+license=('Public domain')
+depends=('python-flask')
+makedepends=('python-distribute')
+source=("http://pypi.python.org/packages/source/p/pycrypto/pycrypto-${pkgver}.tar.gz")
+md5sums=('55a61a054aa66812daf5161a0d5d7eda')
+
+build() {
+
+ cd "${srcdir}/pycrypto-${pkgver}"
+ python ./setup.py build
+
+}
+
+package() {
+
+ cd "${srcdir}/pycrypto-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}