summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLolix2019-06-28 07:23:37 +0200
committerLolix2019-06-28 07:23:37 +0200
commit9db7ecea2f2f372e7435a13c48d9740337db3ccd (patch)
tree161d4643f5b3f556f2ccbfa2e663abfd076085ba
downloadaur-9db7ecea2f2f372e7435a13c48d9740337db3ccd.tar.gz
AUR import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27ec43b6e968
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-pydbus
+ pkgdesc = pythonic D-Bus library
+ pkgver = 0.6.0
+ pkgrel = 4
+ url = https://github.com/LEW21/pydbus
+ arch = any
+ license = LGPL
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-gobject
+ source = pydbus-0.6.0.tar.gz::https://github.com/LEW21/pydbus/archive/v0.6.0.tar.gz
+ sha256sums = dacdf0498a831c8b43a4f3d985d64f99f3093a8aaf4e2ea99981c30fdf1a42da
+
+pkgname = python2-pydbus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d2b372c850d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Maxim Baz <$pkgname at maximbaz dot com>
+# Contributor: Christoph Gysin <christoph.gysin@gmail.com>
+
+_name=pydbus
+pkgname="python2-${_name}"
+pkgver=0.6.0
+pkgrel=4
+pkgdesc="pythonic D-Bus library"
+arch=(any)
+url="https://github.com/LEW21/${_name}"
+license=(LGPL)
+depends=(python2 python2-gobject)
+makedepends=(python2-setuptools)
+# checkdepends=(xorg-server-xvfb python2-gobject)
+source=("${_name}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('dacdf0498a831c8b43a4f3d985d64f99f3093a8aaf4e2ea99981c30fdf1a42da')
+
+build() {
+ cd "${_name}-${pkgver}"
+ python2 setup.py build
+}
+
+# https://github.com/LEW21/pydbus/issues/85
+# check() {
+# cd "${_name}-${pkgver}"
+# # ./tests/run.sh
+# # LANG='en_US.UTF-8' xvfb-run python2 setup.py test
+# }
+
+package() {
+ cd "${_name}-${pkgver}"
+ python2 setup.py install --skip-build \
+ --optimize=1 \
+ --prefix=/usr \
+ --root="${pkgdir}"
+
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.rst
+}