summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclu2015-06-20 19:42:01 -0600
committerclu2015-06-20 19:42:01 -0600
commite3f4631d33cf599470af3b506a5258dedb8cc6a5 (patch)
treef5b8d19e903d2f59ebaf659549401ef758e7684f
downloadaur-e3f4631d33cf599470af3b506a5258dedb8cc6a5.tar.gz
Initial import to aur4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10711fada90a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-pyds9
+ pkgdesc = A Python Connection to DS9 via XPA
+ pkgver = 1.7
+ pkgrel = 1
+ url = http://hea-www.harvard.edu/RD/ds9/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = python2
+ makedepends = python2-distribute
+ depends = python2
+ optdepends = ds9-bin: astronomical data visualization application
+ source = http://hea-www.harvard.edu/RD/download/pyds9/pyds9-1.7.tar.gz
+ sha1sums = 454cef329375f13a14eb0059565c0dc91dd1713d
+
+pkgname = python2-pyds9
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..142c2e88e5d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: <clu>
+
+pkgname=python2-pyds9
+pkgver=1.7
+pkgrel=1
+pkgdesc="A Python Connection to DS9 via XPA"
+url="http://hea-www.harvard.edu/RD/ds9/"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('python2')
+makedepends=('python2' 'python2-distribute')
+optdepends=('ds9-bin: astronomical data visualization application')
+conflicts=()
+replaces=()
+backup=()
+source=(http://hea-www.harvard.edu/RD/download/pyds9/pyds9-$pkgver.tar.gz)
+sha1sums=('454cef329375f13a14eb0059565c0dc91dd1713d')
+
+build() {
+ cd $srcdir/pyds9-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/pyds9-$pkgver
+ python2 setup.py install --root=$pkgdir --prefix=/usr --optimize=1
+}